]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
recipes/classes/scripts: Drop SRCPV usage in OE-Core
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 Aug 2023 13:31:24 +0000 (14:31 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Aug 2023 12:34:35 +0000 (13:34 +0100)
Now that SRCPV isn't needed we can simplify things in a few places...

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
52 files changed:
meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb
meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded
meta-selftest/recipes-test/gitunpackoffline/gitunpackoffline.bb
meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
meta/classes-global/sstate.bbclass
meta/classes-recipe/devupstream.bbclass
meta/classes/externalsrc.bbclass
meta/conf/bitbake.conf
meta/conf/documentation.conf
meta/lib/oe/recipeutils.py
meta/lib/oeqa/selftest/cases/devtool.py
meta/lib/oeqa/selftest/cases/recipetool.py
meta/lib/oeqa/selftest/cases/sstatetests.py
meta/recipes-bsp/efivar/efivar_38.bb
meta/recipes-core/dbus-wait/dbus-wait_git.bb
meta/recipes-core/musl/gcompat_git.bb
meta/recipes-core/musl/libc-test_git.bb
meta/recipes-core/musl/musl-locales_git.bb
meta/recipes-core/musl/musl_git.bb
meta/recipes-core/newlib/newlib.inc
meta/recipes-core/psplash/psplash_git.bb
meta/recipes-devtools/gnu-config/gnu-config_git.bb
meta/recipes-devtools/mmc/mmc-utils_git.bb
meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
meta/recipes-devtools/pseudo/pseudo_git.bb
meta/recipes-devtools/python/python3-dtc_1.6.1.bb
meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
meta/recipes-devtools/xmlto/xmlto_0.0.28.bb
meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb
meta/recipes-graphics/libfakekey/libfakekey_git.bb
meta/recipes-graphics/piglit/piglit_git.bb
meta/recipes-graphics/xcursor-transparent-theme/xcursor-transparent-theme_git.bb
meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
meta/recipes-graphics/xorg-driver/xf86-video-intel_git.bb
meta/recipes-kernel/blktrace/blktrace_git.bb
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
meta/recipes-kernel/linux/linux-yocto-dev.bb
meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
meta/recipes-kernel/linux/linux-yocto_6.1.bb
meta/recipes-kernel/linux/linux-yocto_6.4.bb
meta/recipes-multimedia/x264/x264_git.bb
meta/recipes-sato/l3afpad/l3afpad_git.bb
meta/recipes-sato/matchbox-config-gtk/matchbox-config-gtk_0.2.bb
meta/recipes-sato/matchbox-terminal/matchbox-terminal_0.2.bb
meta/recipes-sato/puzzles/puzzles_git.bb
meta/recipes-support/bmap-tools/bmap-tools_git.bb
meta/recipes-support/ptest-runner/ptest-runner_2.4.2.bb
scripts/lib/recipetool/create.py
scripts/lib/scriptutils.py

index 203f4b61c2ea1770a434164458e57a544cbd48ac..2558a22ce57c7302d24fdb3f3024c7ad07831023 100644 (file)
@@ -8,7 +8,7 @@ DEPENDS = "dbus"
 
 # Note: this is intentionally not the latest version in the original .bb
 SRCREV = "1a3e1343761b30750bed70e0fd688f6d3c7b3717"
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 PR = "r2"
 
 SRC_URI = "git://git.yoctoproject.org/dbus-wait;branch=master"
index 3d45fc48572617a36de9eef530a4bee9b60f30be..eaa8bd898dafbdddc38e213ce45b53affffb59b6 100644 (file)
@@ -8,7 +8,7 @@ DEPENDS = "dbus"
 
 # Note: this is intentionally not the latest version in the original .bb
 SRCREV = "6cc6077a36fe2648a5f993fe7c16c9632f946517"
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 
 SRC_URI = "git://git.yoctoproject.org/dbus-wait;branch=master"
 UPSTREAM_CHECK_COMMITS = "1"
index b051b5da5a10dea3a3f4f3a3c2cf1f8def0e9d6d..d9a54690b2339afcc7239c1b7d0e63f0fbd49e0d 100644 (file)
@@ -2,4 +2,4 @@ require gitunpackoffline.inc
 
 TAGVALUE = "2.11"
 
-PV = "0.0+git${SRCPV}"
+PV = "0.0+git"
index 6062f8422c015b5517f39dd687a03fbcadc6fb46..9437240fcff89bb7304248faf22255ace3dcccbf 100644 (file)
@@ -64,7 +64,7 @@ LINUX_VERSION_EXTENSION:append = "-custom"
 # tag: v4.2 64291f7db5bd8150a74ad2036f1037e6a0428df2
 SRCREV_machine="64291f7db5bd8150a74ad2036f1037e6a0428df2"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 # Override COMPATIBLE_MACHINE to include your machine in a copy of this recipe
 # file. Leaving it empty here ensures an early explicit build failure.
index 95373fd60a597e976c6980571eb17fd48fbf892f..c50198449c24ce4e50e27947f9601cef8945904b 100644 (file)
@@ -769,7 +769,6 @@ def pstaging_fetch(sstatefetch, d):
     localdata.setVar('FILESPATH', dldir)
     localdata.setVar('DL_DIR', dldir)
     localdata.setVar('PREMIRRORS', mirrors)
-    localdata.setVar('SRCPV', d.getVar('SRCPV'))
 
     # if BB_NO_NETWORK is set but we also have SSTATE_MIRROR_ALLOW_NETWORK,
     # we'll want to allow network access for the current set of fetches.
@@ -795,9 +794,6 @@ def pstaging_fetch(sstatefetch, d):
         except bb.fetch2.BBFetchException:
             pass
 
-pstaging_fetch[vardepsexclude] += "SRCPV"
-
-
 def sstate_setscene(d):
     shared_state = sstate_state_fromvars(d)
     accelerate = sstate_installpkg(shared_state, d)
index 1529cc8fca4e6c34bf5cf7ecc54f11636d625c77..d941763fb75cbd01e4a5486a50a788160e405a03 100644 (file)
@@ -46,7 +46,7 @@ python devupstream_virtclass_handler () {
     pv = d.getVar("PV")
     proto_marker = "+" + uri.scheme
     if proto_marker not in pv and not d.getVar("PV:class-devupstream"):
-        d.setVar("PV", pv + proto_marker + "${SRCPV}")
+        d.setVar("PV", pv + proto_marker)
 
     if variant == "native":
         pn = d.getVar("PN")
index 322734f7acabdc94f74e676b120b776bf059f84b..cba80bb1d4d21bcedb33b9116b0e34bfdb90bb2f 100644 (file)
@@ -74,8 +74,6 @@ python () {
 
         d.setVar('SRC_URI', ' '.join(local_srcuri))
 
-        # Dummy value because the default function can't be called with blank SRC_URI
-        d.setVar('SRCPV', '999')
         # sstate is never going to work for external source trees, disable it
         d.setVar('SSTATE_SKIP_CREATION', '1')
 
index c7ada2c49e97c9b1e3a0372184195c3b423e5581..cf7ff3328c408ad51618f6d00015271d437ff7ca 100644 (file)
@@ -961,7 +961,7 @@ BB_SIGNATURE_EXCLUDE_FLAGS ?= "doc deps depends \
     sstate-lockfile-shared prefuncs postfuncs export_func deptask rdeptask \
     recrdeptask nodeprrecs stamp-extra-info sstate-outputdirs filename lineno \
     progress mcdepends number_threads"
-BB_HASH_CODEPARSER_VALS = "LOGFIFO=/ T=/ WORKDIR=/ DATE=1234 TIME=1234 PV=0.0-1 PN=no-pn METADATA_REVISION=1234 SRC_URI= SRCPV=1234"
+BB_HASH_CODEPARSER_VALS = "LOGFIFO=/ T=/ WORKDIR=/ DATE=1234 TIME=1234 PV=0.0-1 PN=no-pn METADATA_REVISION=1234 SRC_URI="
 
 MLPREFIX ??= ""
 MULTILIB_VARIANTS ??= ""
index fc1b4978fd6e7707098f6ef105b394d5b91798c0..23a9c0fe7b319f3d47006422ba1267f673b766ae 100644 (file)
@@ -394,7 +394,6 @@ SPECIAL_PKGSUFFIX[doc] = "A list of prefixes for PN used by the OpenEmbedded bui
 SRC_URI[doc] = "The list of source files - local or remote. This variable tells the OpenEmbedded build system what bits to pull in for the build and how to pull them in."
 SRC_URI_OVERRIDES_PACKAGE_ARCH[doc] = "By default, the OpenEmbedded build system automatically detects whether SRC_URI contains files that are machine-specific. If so, the build system automatically changes PACKAGE_ARCH. Setting this variable to '0' disables this behavior."
 SRCDATE[doc] = "The date of the source code used to build the package. This variable applies only if the source was fetched from a Source Code Manager (SCM)."
-SRCPV[doc] = "Returns the version string of the current package. This string is used to help define the value of PV."
 SRCREV[doc] = "The revision of the source code used to build the package. This variable applies to Subversion, Git, Mercurial and Bazaar only."
 SSTATE_DIR[doc] = "The directory for the shared state cache."
 SSTATE_MIRRORS[doc] = "Configures the OpenEmbedded build system to search other mirror locations for prebuilt cache data objects before building out the data. You can specify a filesystem directory or a remote URL such as HTTP or FTP."
index 5a902c23f6d660bd4f0ceb969b59daffb0ac452d..6996e426ec057c13c0ad06dd447b8560afdb7d61 100644 (file)
@@ -24,7 +24,7 @@ from collections import OrderedDict, defaultdict
 from bb.utils import vercmp_string
 
 # Help us to find places to insert values
-recipe_progression = ['SUMMARY', 'DESCRIPTION', 'HOMEPAGE', 'BUGTRACKER', 'SECTION', 'LICENSE', 'LICENSE_FLAGS', 'LIC_FILES_CHKSUM', 'PROVIDES', 'DEPENDS', 'PR', 'PV', 'SRCREV', 'SRCPV', 'SRC_URI', 'S', 'do_fetch()', 'do_unpack()', 'do_patch()', 'EXTRA_OECONF', 'EXTRA_OECMAKE', 'EXTRA_OESCONS', 'do_configure()', 'EXTRA_OEMAKE', 'do_compile()', 'do_install()', 'do_populate_sysroot()', 'INITSCRIPT', 'USERADD', 'GROUPADD', 'PACKAGES', 'FILES', 'RDEPENDS', 'RRECOMMENDS', 'RSUGGESTS', 'RPROVIDES', 'RREPLACES', 'RCONFLICTS', 'ALLOW_EMPTY', 'populate_packages()', 'do_package()', 'do_deploy()', 'BBCLASSEXTEND']
+recipe_progression = ['SUMMARY', 'DESCRIPTION', 'HOMEPAGE', 'BUGTRACKER', 'SECTION', 'LICENSE', 'LICENSE_FLAGS', 'LIC_FILES_CHKSUM', 'PROVIDES', 'DEPENDS', 'PR', 'PV', 'SRCREV', 'SRC_URI', 'S', 'do_fetch()', 'do_unpack()', 'do_patch()', 'EXTRA_OECONF', 'EXTRA_OECMAKE', 'EXTRA_OESCONS', 'do_configure()', 'EXTRA_OEMAKE', 'do_compile()', 'do_install()', 'do_populate_sysroot()', 'INITSCRIPT', 'USERADD', 'GROUPADD', 'PACKAGES', 'FILES', 'RDEPENDS', 'RRECOMMENDS', 'RSUGGESTS', 'RPROVIDES', 'RREPLACES', 'RCONFLICTS', 'ALLOW_EMPTY', 'populate_packages()', 'do_package()', 'do_deploy()', 'BBCLASSEXTEND']
 # Variables that sometimes are a bit long but shouldn't be wrapped
 nowrap_vars = ['SUMMARY', 'HOMEPAGE', 'BUGTRACKER', r'SRC_URI\[(.+\.)?md5sum\]', r'SRC_URI\[(.+\.)?sha256sum\]']
 list_vars = ['SRC_URI', 'LIC_FILES_CHKSUM']
@@ -421,8 +421,6 @@ def copy_recipe_files(d, tgt_dir, whole_dir=False, download=True, all_variants=F
             # Ensure we handle class-target if we're dealing with one of the variants
             variants.append('target')
             for variant in variants:
-                if variant.startswith("devupstream"):
-                    localdata.setVar('SRCPV', 'git')
                 localdata.setVar('CLASSOVERRIDE', 'class-%s' % variant)
                 fetch_urls(localdata)
 
index 14a80d5ff4c585f195e49eb30d4fdb9ecbb741ce..a2b77e528dee1dfd2ec67974693c3414fa43d5f3 100644 (file)
@@ -433,7 +433,7 @@ class DevtoolAddTests(DevtoolBase):
         checkvars['LICENSE'] = 'GPL-2.0-only'
         checkvars['LIC_FILES_CHKSUM'] = 'file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263'
         checkvars['S'] = '${WORKDIR}/git'
-        checkvars['PV'] = '0.1+git${SRCPV}'
+        checkvars['PV'] = '0.1+git'
         checkvars['SRC_URI'] = 'git://git.yoctoproject.org/git/dbus-wait;protocol=https;branch=master'
         checkvars['SRCREV'] = srcrev
         checkvars['DEPENDS'] = set(['dbus'])
@@ -572,7 +572,7 @@ class DevtoolAddTests(DevtoolBase):
         self.assertIn('_git.bb', recipefile, 'Recipe file incorrectly named')
         checkvars = {}
         checkvars['S'] = '${WORKDIR}/git'
-        checkvars['PV'] = '1.0+git${SRCPV}'
+        checkvars['PV'] = '1.0+git'
         checkvars['SRC_URI'] = url_branch
         checkvars['SRCREV'] = '${AUTOREV}'
         self._test_recipe_contents(recipefile, checkvars, [])
@@ -591,7 +591,7 @@ class DevtoolAddTests(DevtoolBase):
         self.assertIn('_git.bb', recipefile, 'Recipe file incorrectly named')
         checkvars = {}
         checkvars['S'] = '${WORKDIR}/git'
-        checkvars['PV'] = '1.5+git${SRCPV}'
+        checkvars['PV'] = '1.5+git'
         checkvars['SRC_URI'] = url_branch
         checkvars['SRCREV'] = checkrev
         self._test_recipe_contents(recipefile, checkvars, [])
index a5c0f7164a32c88c3266415e1249cb2faccce2e9..48661bee6f24cf56fa5eea16d29cd75aad33f539 100644 (file)
@@ -368,7 +368,7 @@ class RecipetoolCreateTests(RecipetoolBase):
         checkvars['LICENSE'] = 'LGPL-2.1-only'
         checkvars['LIC_FILES_CHKSUM'] = 'file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34'
         checkvars['S'] = '${WORKDIR}/git'
-        checkvars['PV'] = '1.11+git${SRCPV}'
+        checkvars['PV'] = '1.11+git'
         checkvars['SRC_URI'] = srcuri + ';branch=master'
         checkvars['DEPENDS'] = set(['libcheck', 'libjpeg-turbo', 'libpng', 'libx11', 'libxext', 'pango'])
         inherits = ['autotools', 'pkgconfig']
index 3fa3038218c075e74f377bec7859519d89f44b60..bdad9088d3730a926609dcdaaa0e01bbab4c2a6b 100644 (file)
@@ -188,7 +188,6 @@ class SStateBase(OESelftestTestCase):
 class SStateTests(SStateBase):
     def test_autorev_sstate_works(self):
         # Test that a git repository which changes is correctly handled by SRCREV = ${AUTOREV}
-        # when PV does not contain SRCPV
 
         tempdir = tempfile.mkdtemp(prefix='sstate_autorev')
         tempdldir = tempfile.mkdtemp(prefix='sstate_autorev_dldir')
index 411e951a5a06d35480a370c089aa9cb8057f873b..d88eb3fef53bdfb1e7f57284e64affdd2071e370 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
            file://0001-docs-do-not-build-efisecdb-manpage.patch \
            "
 SRCREV = "90e88b221e8bc60dc50f3246051369b8f580c0d0"
-PV .= "+39+git${SRCPV}"
+PV .= "+39+git"
 
 S = "${WORKDIR}/git"
 
index bc846de2169ac32d10ca45db03f30af0307c9db7..09ba515a61e95d5512b38fd1329cdda1986ecb0f 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 DEPENDS = "dbus"
 
 SRCREV = "6cc6077a36fe2648a5f993fe7c16c9632f946517"
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 PR = "r2"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https"
index 11f3c58769e6d207b840c4eb8d64fe7693f9582c..ba802e3caaa9cc6015155f144b4a00dd157898fe 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI = "git://git.adelielinux.org/adelie/gcompat.git;protocol=https;branch=cu
 SRC_URI:append:powerpc = "\
            file://0001-make-Static-PIE-does-not-work-on-musl-ppc.patch \
            "
-PV = "1.0.0+1.1+git${SRCPV}"
+PV = "1.0.0+1.1+git"
 SRCREV = "c6921a1aa454bb87671f9bd1ecfe47d80d1620aa"
 
 S = "${WORKDIR}/git"
index 6d64592f0c611e9ad42367cefcf21b81f4112809..d18c967e138afb1ea36ca7dd2036b64ba5ceaa47 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI = " \
     file://run-ptest \
 "
 
-PV = "0+git${SRCPV}"
+PV = "0+git"
 
 S = "${WORKDIR}/git"
 
index 6ffac4fadedaf6d1ae84f25a13c86d259d91b345..1373c60daf4dd21c5647f637755cd2e723781789 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=cf5713fba707073020b1db2acaa73e78 \
 
 SRC_URI = "git://git.adelielinux.org/adelie/musl-locales;protocol=https;branch=main"
 
-PV = "1.0+git${SRCPV}"
+PV = "1.0+git"
 SRCREV = "5663f5bfd30bf9e1e0ba3fc5fe2da6725969f30e"
 
 S = "${WORKDIR}/git"
index 297c5581a373045e030e884595914a1c44da0d04..4a4fe978f934c6ccb4b52b8b3318f8f5e8820c65 100644 (file)
@@ -8,7 +8,7 @@ SRCREV = "83b858f83b658bd34eca5d8ad4d145f673ae7e5e"
 
 BASEVER = "1.2.4"
 
-PV = "${BASEVER}+git${SRCPV}"
+PV = "${BASEVER}+git"
 
 # mirror is at git://github.com/kraj/musl.git
 
index 5351a9f99122915878d14324b356b2d781f6e4e0..da753f11adab9616f3a80cb93e31a0da2affaf90 100644 (file)
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = " \
                "
 
 BASEVER = "4.3.0"
-PV = "${BASEVER}+git${SRCPV}"
+PV = "${BASEVER}+git"
 SRC_URI = "git://sourceware.org/git/newlib-cygwin.git;protocol=https;branch=main"
 SRCREV="9e09d6ed83cce4777a5950412647ccc603040409"
 
index 78960e1e4cce5afde8cdc4dd37cc0148bd4f8683..17704a02f6921b90fb53b2f70c31d0b704c82565 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=8f232c1e95929eaca
 DEPENDS = "gdk-pixbuf-native"
 
 SRCREV = "44afb7506d43cca15582b4c5b90ba5580344d75d"
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https \
            file://psplash-init \
index 080704753d1d05e5b3d30ad54c53ad781ad0faeb..2a0e6f8e41f99d165ff5f537cb6ace151ae9acc8 100644 (file)
@@ -10,7 +10,7 @@ DEPENDS:class-native = "hostperl-runtime-native"
 INHIBIT_DEFAULT_DEPS = "1"
 
 SRCREV = "63acb96f92473ceb5e21d873d7c0aee266b3d6d3"
-PV = "20230216+git${SRCPV}"
+PV = "20230216+git"
 
 SRC_URI = "git://git.savannah.gnu.org/git/config.git;protocol=https;branch=master \
            file://gnu-configize.in"
index 373ada2026aaa9b516bc43be96637e06c9dbb4c2..879c179dd73416dca54ed0882f53e5edb5ad9e90 100644 (file)
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=20;md5=fae32792e20f4d27ade1
 SRCBRANCH ?= "master"
 SRCREV = "958227890690290ee766aaad1b92f3413f67048c"
 
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRCBRANCH};protocol=https"
 UPSTREAM_CHECK_COMMITS = "1"
index 68f624c80a306b090a898aaf9deaa2d2884ce2b6..16e6c5b6099d76c307683c312ded88e6b89009e8 100644 (file)
@@ -9,7 +9,7 @@ LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
 SRCREV = "d97db4fae4c1cd099b506970b285dc2afd818ea2"
-PV = "0.29.2+git${SRCPV}"
+PV = "0.29.2+git"
 
 SRC_URI = "git://gitlab.freedesktop.org/pkg-config/pkg-config.git;branch=master;protocol=https \
            file://pkg-config-esdk.in \
index 9260a3faa34a4b0bc36c7321ba9b5b4611329d2f..4a894ebdd0bff6ec11a6d6d97778e5677358171e 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI[prebuilt.sha256sum] = "ed9f456856e9d86359f169f46a70ad7be4190d6040282b84c
 
 SRCREV = "ec6151a2b057109b3f798f151a36690af582e166"
 S = "${WORKDIR}/git"
-PV = "1.9.0+git${SRCPV}"
+PV = "1.9.0+git"
 
 # largefile and 64bit time_t support adds these macros via compiler flags globally
 # remove them for pseudo since pseudo intercepts some of the functions which will be
index a868bd0109dd89f3161b08d14e71939faf988c99..95ab0be47474374a0b9780b935eb059c9e21b821 100644 (file)
@@ -16,7 +16,7 @@ LIC_FILES_CHKSUM = "file://pylibfdt/libfdt.i;beginline=1;endline=6;md5=afda088c9
 
 SRCREV = "c001fc01a43e7a06447c06ea3d50bd60641322b8"
 
-PV = "1.6.1+git${SRCPV}"
+PV = "1.6.1+git"
 S = "${WORKDIR}/git"
 
 PYPA_WHEEL = "${S}/dist/libfdt-1.6.2*.whl"
index 7d151d4642a2aa2c6bba203f30b964f871a94fbe..4d2ca5f1b0bcdc9888c5457e7c20d1a52ddd9f6c 100644 (file)
@@ -7,7 +7,7 @@ LICENSE = "EPL-1.0 | EDL-1.0"
 LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
 
 SRCREV = "1f11747e83ebf4f53e8d17f430136f92ec378709"
-PV = "1.8.0+git${SRCPV}"
+PV = "1.8.0+git"
 
 UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
 SRC_URI = "git://git.eclipse.org/r/tcf/org.eclipse.tcf.agent.git;protocol=https;branch=master \
index 5e3fac7a60cd7d9f5f683f859fb7267ac2210256..d5a0e69849e5adf6a8e76d764af12d23b006025b 100644 (file)
@@ -11,7 +11,7 @@ UPSTREAM_CHECK_COMMITS = "1"
 SRC_URI = "git://pagure.io/xmlto.git;protocol=https;branch=master"
 S = "${WORKDIR}/git"
 
-PV .= "+0.0.29+git${SRCPV}"
+PV .= "+0.0.29+git"
 
 inherit autotools
 
index c5d3e04ed558023b834cb971d53ac19a700216fe..fde75ec2fd9934a4896c52ee047a3d5d4247f503 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
 
 SRCREV = "fc7c43d138185028b6ac14c83f6492fce26eca95"
-PV = "0.1+git${SRCPV}"
+PV = "0.1+git"
 
 SRC_URI = "git://github.com/ahcbb6/baremetal-helloqemu.git;protocol=https;branch=master"
 UPSTREAM_VERSION_UNKNOWN="1"
index c9c828a8c422dd4735eb755e8aefee1dba31743b..5f902d3a67e80479d945b02b6287406b5ecdb24a 100644 (file)
@@ -11,7 +11,7 @@ DEPENDS = "libxtst"
 SECTION = "x11/wm"
 
 SRCREV = "7ad885912efb2131e80914e964d5e635b0d07b40"
-PV = "0.3+git${SRCPV}"
+PV = "0.3+git"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https"
 
index cd97ee53547dd169d91f5c155d5c568be5e1e2a7..62cada759062ec215f9cf1ed9ba3fa02cb7ec4e0 100644 (file)
@@ -16,7 +16,7 @@ UPSTREAM_CHECK_COMMITS = "1"
 
 SRCREV = "5036601c43fff63f7be5cd8ad7b319a5c1f6652c"
 # (when PV goes above 1.0 remove the trailing r)
-PV = "1.0+gitr${SRCPV}"
+PV = "1.0+gitr"
 
 S = "${WORKDIR}/git"
 
index b65a3bea5628cbd787326adbb7573ec0fc22ae10..40b77422bf6993be1fb6389ebe64026b51eb2a8e 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 SECTION = "x11/base"
 
 SRCREV = "23c8af5ba4a1b7efbaf0bbca59a65ff7e10a1a06"
-PV = "0.1.1+git${SRCPV}"
+PV = "0.1.1+git"
 
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https"
 UPSTREAM_CHECK_COMMITS = "1"
index 3f49df6258b9428748f0416fb13998ab613fe738..05f07c190e9012b495435f10f720e0f5bc729cc1 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a"
 DEPENDS = "virtual/libx11 libxi libxrandr"
 
-PV = "0.7.5+git${SRCPV}"
+PV = "0.7.5+git"
 PR = "r6"
 
 inherit autotools pkgconfig features_check
index 21b499e66661309a9595e6d147f95700a91a07fa..2e526bd799989da059c8af5527a9431daf761a0a 100644 (file)
@@ -10,7 +10,7 @@ Infrastructure (DRI)."
 LIC_FILES_CHKSUM = "file://COPYING;md5=8730ad58d11c7bbad9a7066d69f7808e"
 
 SRCREV = "31486f40f8e8f8923ca0799aea84b58799754564"
-PV = "2.99.917+git${SRCPV}"
+PV = "2.99.917+git"
 S = "${WORKDIR}/git"
 
 SRC_URI = "git://anongit.freedesktop.org/git/xorg/driver/xf86-video-intel;protocol=https;branch=master"
index d0eeba3208863e959f2ff688cf57ea56e6da12d1..d4f5bac84f168c0e1a1d4a83b8a2a47484c6ea8b 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "libaio"
 
 SRCREV = "366d30b9cdb20345c5d064af850d686da79b89eb"
 
-PV = "1.3.0+git${SRCPV}"
+PV = "1.3.0+git"
 
 SRC_URI = "git://git.kernel.dk/blktrace.git;branch=master;protocol=https"
 
index cea12240f0e0e96b6f31637ed58c3d4ebbcdd97a..3fcfe4b4c31fefa1cb8ff7e8a231be7c22e4ffbf 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "\
 DEPENDS = "git-native"
 
 SRCREV = "6645d3897cc2eeb1237ee0e2ff5342bd73ee0875"
-PV = "0.3+git${SRCPV}"
+PV = "0.3+git"
 
 inherit native
 
index fba603b0f2b8258da549462e51cc3622ab03c021..95e359273180e0fcffa41a9a31466a920f614118 100644 (file)
@@ -30,7 +30,7 @@ SRCREV_meta ?= '${@oe.utils.conditional("PREFERRED_PROVIDER_virtual/kernel", "li
 
 LINUX_VERSION ?= "6.5"
 LINUX_VERSION_EXTENSION ?= "-yoctodev-${LINUX_KERNEL_TYPE}"
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 
index d13722b32f7b59a331a7fbbc28ffce589cc29600..be2110ecc9bd3d1e879cc7ebfb52369577d0acd0 100644 (file)
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
 DEPENDS += "openssl-native util-linux-native"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "1"
index 5f633405ead93d537420f276375f9839a6d0ac10..3c168def2cb4c4d2352eca44d4cd005d74c61f24 100644 (file)
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
 DEPENDS += "openssl-native util-linux-native"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "1"
index a77bd9d183c922577c5471c35941766db0d8d931..6b452f3803d360befd5b1bbcc7609c2994d5d678 100644 (file)
@@ -20,7 +20,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 SRCREV_machine ?= "44fd0c7a5a7955282a1ab24bf3dcdee068839ad2"
 SRCREV_meta ?= "295d37e268bc02070da670e46456227bee38795b"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
index 982352b0109d7670b46f841b9807d8f1adeb01a9..721b52bc8aa9a6eb465b75c3e9d21fd5078bc345 100644 (file)
@@ -20,7 +20,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 SRCREV_machine ?= "9753b4497951a5bd1a921e784532257d26a8b008"
 SRCREV_meta ?= "d9483a24c9ee33b6e566baa5233cbd9feaeb5212"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.4;destsuffix=${KMETA};protocol=https"
index deed2115c4ca4fde09278a4d374b864808f1f380..b4601f583e796fd9344622d7d529c317e7e0aa30 100644 (file)
@@ -47,7 +47,7 @@ SRC_URI += "file://0001-perf-cpumap-Make-counter-as-unsigned-ints.patch"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 LINUX_VERSION ?= "6.1.46"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "1"
index ce406db90e2f089475ac047a91ba4f50de8319aa..52accc9f877e410be5b0d760db9f5a3e3a108ee0 100644 (file)
@@ -46,7 +46,7 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
 LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
 LINUX_VERSION ?= "6.4.11"
 
-PV = "${LINUX_VERSION}+git${SRCPV}"
+PV = "${LINUX_VERSION}+git"
 
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "1"
index 2ac2b6f1a6714d55f06a9b966a0776c7b4580278..e7d9e75e8dea6b2ad279a0bc60ea1cbb3b5e1608 100644 (file)
@@ -16,7 +16,7 @@ UPSTREAM_CHECK_COMMITS = "1"
 
 SRCREV = "baee400fa9ced6f5481a728138fed6e867b0ff7f"
 
-PV = "r3039+git${SRCPV}"
+PV = "r3039+git"
 
 S = "${WORKDIR}/git"
 
index 56cbe6bc8d323c89b9471c904f2d60f068e45c2b..55400839284a825d4ba8a8a1456e0113a3351eec 100644 (file)
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
 
 DEPENDS = "gtk+3 intltool-native gettext-native"
 
-PV = "0.8.18.1.11+git${SRCPV}"
+PV = "0.8.18.1.11+git"
 SRC_URI = "git://github.com/stevenhoneyman/l3afpad.git;branch=master;protocol=https"
 SRCREV ="3cdccdc9505643e50f8208171d9eee5de11a42ff"
 
index 490bd582b254048797f4d30968e806f19be02ee5..caa34966ccc1d6ef1d29686aecc3d925f486f88c 100644 (file)
@@ -13,7 +13,7 @@ SRCREV = "7182e603357250952aa24d90f6d89345f93da7ce"
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https \
            file://no-handed.patch"
 UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
-PV = "0.2+git${SRCPV}"
+PV = "0.2+git"
 
 S = "${WORKDIR}/git"
 
index a1f236b40ffb46865abaae8af7868d52096aca78..f91c593f784b10363f2ab57c44634b8ba8ab14e2 100644 (file)
@@ -12,7 +12,7 @@ SECTION = "x11/utils"
 SRCREV = "99e6eb7db1b5fef110973d96194eec992a2515a2"
 SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https"
 UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
-PV = "0.2+git${SRCPV}"
+PV = "0.2+git"
 
 S = "${WORKDIR}/git"
 
index 960b5d3b1102054492ff2b9826a955eddabbe0bd..04338a603b5a559042aa62786e07d7845095fc5f 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI = "git://git.tartarus.org/simon/puzzles.git;branch=main;protocol=https"
 UPSTREAM_CHECK_COMMITS = "1"
 SRCREV = "b6c842a28cf6597df063fcff35079c3e3982381e"
 PE = "2"
-PV = "0.0+git${SRCPV}"
+PV = "0.0+git"
 
 S = "${WORKDIR}/git"
 
index 89b7bf2b93c321cea830fe988448b229a4674d84..1de95c8e5243529030c4bbb346499ef3f5413430 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/intel/${BPN};branch=main;protocol=https"
 SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a"
 S = "${WORKDIR}/git"
 BASEVER = "3.6"
-PV = "${BASEVER}+git${SRCPV}"
+PV = "${BASEVER}+git"
 
 UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
 
index 60918a3892716a0271e3dd1b8a0ce73607727cf6..ff336b382081f4d2d3822bf09e74f3defc43b758 100644 (file)
@@ -8,7 +8,7 @@ LICENSE = "GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
 
 SRCREV = "4148e75284e443fc8ffaef425c467aa5523528ff"
-PV .= "+git${SRCPV}"
+PV .= "+git"
 
 SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \
 "
index e99e0714bf4b9ad7625c7b59d814148344038e3b..f9dda3c2f966438ac5f60c8a03872bb86f6575fb 100644 (file)
@@ -690,7 +690,7 @@ def create_recipe(args):
             srcpvprefix = 'svnr'
         else:
             srcpvprefix = scheme
-        lines_before.append('PV = "%s+%s${SRCPV}"' % (realpv or '1.0', srcpvprefix))
+        lines_before.append('PV = "%s+%s"' % (realpv or '1.0', srcpvprefix))
         pv_srcpv = True
         if not args.autorev and srcrev == '${AUTOREV}':
             if os.path.exists(os.path.join(srctree, '.git')):
index f433106c9a88b15e421b13c48133dc098d6b6e79..f23e53cba93565d1dd3cc9f1960ec4451be90941 100644 (file)
@@ -177,7 +177,7 @@ def fetch_url(tinfoil, srcuri, srcrev, destdir, logger, preserve_tmp=False, mirr
                 f.write('BB_STRICT_CHECKSUM = "ignore"\n')
                 f.write('SRC_URI = "%s"\n' % srcuri)
                 f.write('SRCREV = "%s"\n' % srcrev)
-                f.write('PV = "0.0+${SRCPV}"\n')
+                f.write('PV = "0.0+"\n')
                 f.write('WORKDIR = "%s"\n' % tmpworkdir)
                 # Set S out of the way so it doesn't get created under the workdir
                 f.write('S = "%s"\n' % os.path.join(tmpdir, 'emptysrc'))