]> git.ipfire.org Git - thirdparty/binutils-gdb.git/blobdiff - sim/d10v/configure.in
Make exit/stop return correct exit value; Add line number tracing.
[thirdparty/binutils-gdb.git] / sim / d10v / configure.in
index 647255eff7db139b54351a9c84b4adf7688fdef5..cc9c4ad4951fb88973868a68f5e83b4485cce90c 100644 (file)
@@ -23,7 +23,7 @@ AC_ARG_ENABLE(sim-cflags,
 [  --enable-sim-cflags=opts            Extra CFLAGS for use in building simulator],
 [case "${enableval}" in
   yes)  sim_cflags="-O2";;
-  trace) sim_cflags="-O2 -DDEBUG=3";;
+  trace) AC_MSG_ERROR("Please use --enable-sim-debug instead."); sim_cflags="";;
   no)   sim_cflags="";;
   *)    sim_cflags=`echo "${enableval}" | sed -e "s/,/ /g"`;;
 esac
@@ -31,6 +31,17 @@ if test x"$silent" != x"yes" && test x"$sim_cflags" != x""; then
   echo "Setting sim cflags = $sim_cflags" 6>&1
 fi],[sim_cflags=""])dnl
 
+AC_ARG_ENABLE(sim-debug,
+[  --enable-sim-debug=opts             Enable debugging flags],
+[case "${enableval}" in
+  yes) sim_debug="-DDEBUG=7";;
+  no)  sim_debug="-DDEBUG=0";;
+  *)   sim_debug="-DDEBUG='(${enableval})'";;
+esac
+if test x"$silent" != x"yes" && test x"$sim_debug" != x""; then
+  echo "Setting sim debug = $sim_debug" 6>&1
+fi],[sim_cflags=""])dnl
+
 AC_SUBST(CC_FOR_BUILD)
 AC_SUBST(CFLAGS)
 AC_SUBST(HDEFINES)
@@ -38,6 +49,7 @@ AR=${AR-ar}
 AC_SUBST(AR)
 AC_PROG_RANLIB
 AC_SUBST(sim_cflags)
+AC_SUBST(sim_debug)
 
 # Put a plausible default for CC_FOR_BUILD in Makefile.
 AC_C_CROSS