]> git.ipfire.org Git - thirdparty/binutils-gdb.git/blobdiff - sim/v850/configure.ac
sim: switch to AC_CHECK_HEADERS_ONCE
[thirdparty/binutils-gdb.git] / sim / v850 / configure.ac
index 1ccb8ea500c6caac7cfe8304340c97f82dba60b6..f2edf1f7c4800f0709b968ea867a7dee035bfce1 100644 (file)
@@ -1,18 +1,15 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.59)dnl
 AC_INIT(Makefile.in)
+AC_CONFIG_MACRO_DIRS([../m4 ../.. ../../config])
 
-sinclude(../common/common.m4)
-sinclude(../common/aclocal.m4)
+SIM_AC_COMMON
 
-SIM_AC_OPTION_ENDIAN(LITTLE_ENDIAN)
+SIM_AC_OPTION_ENDIAN(LITTLE)
 SIM_AC_OPTION_ALIGNMENT(,NONSTRICT_ALIGNMENT)
-SIM_AC_OPTION_HOSTENDIAN
-SIM_AC_OPTION_WARNINGS
 SIM_AC_OPTION_RESERVED_BITS
 SIM_AC_OPTION_BITSIZE(32,31)
 
-AC_CHECK_FUNCS(time chmod utime fork execve execv chown)
-AC_CHECK_HEADERS(unistd.h stdlib.h string.h strings.h utime.h time.h)
+AC_CHECK_FUNCS_ONCE(chmod utime fork execve execv chown)
+AC_CHECK_HEADERS_ONCE(utime.h)
 
 SIM_AC_OUTPUT