]> git.ipfire.org Git - thirdparty/gcc.git/blobdiff - intl/configure.ac
Revert "configure: Implement --enable-host-pie"
[thirdparty/gcc.git] / intl / configure.ac
index 81aa831f59fdc1c512c76f8f22311e09c079a00d..16a740aa230aa29971893b3a59f7a570299e1a45 100644 (file)
@@ -83,25 +83,10 @@ fi
 AC_SUBST(BISON3_YES)
 AC_SUBST(BISON3_NO)
 
-# Enable --enable-host-shared.
 AC_ARG_ENABLE(host-shared,
 [AS_HELP_STRING([--enable-host-shared],
-       [build host code as shared libraries])])
-AC_SUBST(enable_host_shared)
-
-# Enable --enable-host-pie.
-AC_ARG_ENABLE(host-pie,
-[AS_HELP_STRING([--enable-host-pie],
-       [build host code as PIE])])
-AC_SUBST(enable_host_pie)
-
-if test x$enable_host_shared = xyes; then
-  PICFLAG=-fPIC
-elif test x$enable_host_pie = xyes; then
-  PICFLAG=-fPIE
-else
-  PICFLAG=
-fi
+               [build host code as shared libraries])],
+[PICFLAG=-fPIC], [PICFLAG=])
 AC_SUBST(PICFLAG)
 
 AC_CONFIG_FILES(Makefile config.intl)