]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/blame - meta/recipes-graphics/wayland/wayland_1.10.0.bb
wayland-protocols: Upgrade 1.3 -> 1.4
[thirdparty/openembedded/openembedded-core-contrib.git] / meta / recipes-graphics / wayland / wayland_1.10.0.bb
CommitLineData
41538cb5
AD
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
696895e3
DD
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
7d278ef0
JK
13SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
14SRC_URI[md5sum] = "e7751c38807c231afaba9d6b68f2a2b7"
15SRC_URI[sha256sum] = "4bf6e790aa6f50ab3825676282ecd75850ec9c4767af96ecb7127b1f3c3d60dc"
696895e3
DD
16
17EXTRA_OECONF_class-native = "--disable-documentation --disable-libraries"
bfbe9b6a 18
41538cb5
AD
19inherit autotools pkgconfig
20
1f19083e 21BBCLASSEXTEND = "native nativesdk"
41538cb5 22
7d278ef0 23DEPENDS = "expat libxml2 libffi wayland-native"
41538cb5 24
7aeeaf28 25EXTRA_OECONF = "--disable-documentation --with-host-scanner"
41538cb5 26
97a3c3bc
RB
27# Wayland installs a M4 macro for other projects to use, which uses the target
28# pkg-config to find files. Replace pkg-config with pkg-config-native.
29do_install_append_class-native() {
30 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
31 -e 's,$PKG_CONFIG,pkg-config-native,g' \
32 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
41538cb5 33}
ad9bd9ce
RP
34
35sysroot_stage_all_append_class-target () {
8f3be192 36 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
ad9bd9ce
RP
37 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
38}
7aeeaf28
RB
39
40FILES_${PN} = "${libdir}/*${SOLIBS}"
41FILES_${PN}-dev += "${bindir} ${datadir}/wayland"