]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/blame - meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
targetloader.py: drop test for ClassType
[thirdparty/openembedded/openembedded-core.git] / meta / recipes-multimedia / libtiff / tiff_4.0.6.bb
CommitLineData
b8feee3c 1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
3083dd70 2LICENSE = "BSD-2-Clause"
39611d32 3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
dc5aa58b 4
fa107101
RB
5CVE_NAME = "libtiff"
6
f544e1d1 7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
9db7a897 8 file://libtool2.patch \
b7a38a45 9 file://CVE-2015-8665_8683.patch \
9e97ff55 10 file://CVE-2015-8781.patch \
36097da9 11 file://CVE-2015-8784.patch \
3d818fc8 12 file://CVE-2016-3186.patch \
4a167cfb 13 file://CVE-2016-5321.patch \
4ad1220e 14 file://CVE-2016-5323.patch \
04b9405c 15 file://CVE-2016-3945.patch \
c6492563 16 file://CVE-2016-3990.patch \
d3126743 17 file://CVE-2016-3991.patch \
d66824ee 18 file://CVE-2016-3623.patch \
0af0466f 19 file://CVE-2016-3622.patch \
c060e91d 20 file://CVE-2016-3658.patch \
9206c862 21 file://CVE-2016-3632.patch \
cc97dc66 22 file://CVE-2016-9540.patch \
58bf0a23 23 file://CVE-2016-9539.patch \
61d3feb9
MY
24 file://CVE-2016-9535-1.patch \
25 file://CVE-2016-9535-2.patch \
9af5d5ea 26 file://CVE-2016-9538.patch \
f75ecefe 27 file://Fix_several_CVE_issues.patch \
5c5d7c2a 28 "
dc5aa58b 29
88a2a8f2
AK
30SRC_URI[md5sum] = "d1d2e940dea0b5ad435f21f03d96dd72"
31SRC_URI[sha256sum] = "4d57a50907b510e3049a4bba0d7888930fdfc16ce49f1bf693e5b6247370d68c"
3d08b9f2 32
1eb9e190
AK
33# exclude betas
34UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
35
4d1f39af 36inherit autotools
dc5aa58b 37
69e67ac7
SW
38CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
39
314b0718
CL
40PACKAGECONFIG ?= "cxx jpeg zlib lzma \
41 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
42
43PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
44PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
45PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
46PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
47
48# Convert single-strip uncompressed images to multiple strips of specified
49# size (default: 8192) to reduce memory usage
50PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
51
52# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
53PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
54
55# Control picking up YCbCr subsample info. Disable to support files lacking
56# the tag
57PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
58
59# Support a mechanism allowing reading large strips (usually one strip files)
60# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
61PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
62
dd65ee47 63PACKAGES =+ "tiffxx tiff-utils"
dc5aa58b 64FILES_tiffxx = "${libdir}/libtiffxx.so.*"
dc5aa58b 65FILES_tiff-utils = "${bindir}/*"
fef8ef18
MJ
66
67BBCLASSEXTEND = "native"