]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/blame - meta/recipes-multimedia/libtiff/tiff_4.6.0.bb
tiff: fix CVE-2023-6228
[thirdparty/openembedded/openembedded-core.git] / meta / recipes-multimedia / libtiff / tiff_4.6.0.bb
CommitLineData
b8feee3c 1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
31299426
MMID
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
3083dd70 6LICENSE = "BSD-2-Clause"
9a255a3b 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
dc5aa58b 8
0c8d1523 9CVE_PRODUCT = "libtiff"
fa107101 10
c3d4fbeb 11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
a2d0f36a
KR
12 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data.patch \
13 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data-2.patch \
14 file://CVE-2023-6277-Apply-1-suggestion-s-to-1-file-s.patch \
fe0ee74a 15 file://CVE-2023-6228.patch \
c3d4fbeb 16 "
9a255a3b 17
9e80f93a 18SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
3d08b9f2 19
1eb9e190
AK
20# exclude betas
21UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
22
1634ed40 23CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
34e6a19f 24
53f32079 25inherit autotools multilib_header
dc5aa58b 26
69e67ac7
SW
27CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
28
314b0718
CL
29PACKAGECONFIG ?= "cxx jpeg zlib lzma \
30 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
31
32PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
34e6a19f 33PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
314b0718
CL
34PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
35PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
36PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
718c44f2 37PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
ca2e2035
MV
38PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
39PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
314b0718
CL
40
41# Convert single-strip uncompressed images to multiple strips of specified
42# size (default: 8192) to reduce memory usage
43PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
44
45# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
46PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
47
48# Control picking up YCbCr subsample info. Disable to support files lacking
49# the tag
50PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
51
52# Support a mechanism allowing reading large strips (usually one strip files)
53# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
54PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
55
dd65ee47 56PACKAGES =+ "tiffxx tiff-utils"
42344347
RP
57FILES:tiffxx = "${libdir}/libtiffxx.so.*"
58FILES:tiff-utils = "${bindir}/*"
fef8ef18 59
42344347 60do_install:append() {
53f32079
ZX
61 oe_multilib_header tiffconf.h
62}
63
929cf038 64BBCLASSEXTEND = "native nativesdk"