]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] add a block device with a ! in the name, and a test for this.
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
0c675896
GKH
14# if we want to build DBUS support in or not.
15# 0 - no DBUS support
16# 1 - DBUS support
17%define dbus 0
18
19# if we want to enable debugging support in udev. If it is enabled, lots of
20# stuff will get sent to the debug syslog.
21# 0 - debugging disabled
22# 1 - debugging enabled
23%define debug 0
24
e64280b8 25# if we want to use the LSB version of the init script or the Redhat one
26# 0 - use Redhat version: etc/init.d/udev
27# 1 - use LSB version: etc/init.d/udev.init.LSB
28%define lsb 0
29
3660f0b8
PM
30Summary: A userspace implementation of devfs
31Name: udev
16be1328 32Version: 016_bk
3660f0b8
PM
33Release: 1
34License: GPL
35Group: Utilities/System
36Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37ExclusiveOS: Linux
e0929206 38Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 39URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 40BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 41Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
42
43%description
44udev is a implementation of devfs in userspace using sysfs and
22120496 45/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
46
47%prep
bbab56ba 48%setup -q
3660f0b8
PM
49
50%build
0c675896
GKH
51make CC="gcc $RPM_OPT_FLAGS" \
52%if %{klibc}
53 USE_KLIBC=true \
54%endif
05230184
GKH
55%if %{log}
56 USE_LOG=true \
57%endif
0c675896
GKH
58%if %{dbus}
59 USE_DBUS=true \
60%endif
61%if %{debug}
62 DEBUG=true \
63%endif
3660f0b8 64
d83a9b89
GKH
65# now build udevd on it's own, as it can't handle being built with klibc
66make CC="gcc $RPM_OPT_FLAGS" udevd
67
68
3660f0b8 69%install
5bfabc59 70make DESTDIR=$RPM_BUILD_ROOT install \
71%if %{dbus}
72 USE_DBUS=true
73%endif
e64280b8 74%if %{lsb}
75 USE_LSB=true
76%endif
316c5150 77%post
78/sbin/chkconfig --add udev
79
600ee7f7 80%postun
81if [ $1 = 0 ]; then
82 /sbin/chkconfig --del udev
83fi
84
3660f0b8 85%clean
bbab56ba 86rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
87
88%files
ee156981 89%defattr(-,root,root)
bbab56ba
RL
90%doc COPYING README TODO ChangeLog
91%attr(755,root,root) /sbin/udev
da1cc7cc 92%attr(755,root,root) /sbin/udevinfo
d83a9b89
GKH
93%attr(755,root,root) /sbin/udevsend
94%attr(755,root,root) /sbin/udevd
bbab56ba
RL
95%attr(755,root,root) /udev/
96%attr(755,root,root) /etc/udev/
1b1dbc47 97%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
98%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
99%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
5bfabc59 100%if %{dbus}
101 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
102%endif
8634e6d1 103%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 104%attr(755,root,root) /etc/init.d/udev
567f6d14 105%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3660f0b8
PM
106
107%changelog
d83a9b89
GKH
108* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
109- add udevsend, and udevd to the files
110- add ability to build udevd with glibc after the rest is build with klibc
111
da1cc7cc 112* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 113- added udevinfo to rpm
8fc34188 114- added URL to spec file
567f6d14 115- added udevinfo's man page
da1cc7cc 116
e64280b8 117* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
118- add defines to choose the init script (Redhat or LSB)
119
316c5150 120* Tue Dec 16 2003 Robert Love <rml@ximian.com>
121- install the initscript and run chkconfig on it
122
e8baccca
GKH
123* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
124- changes due to config file name changes
125
bbab56ba
RL
126* Fri Oct 17 2003 Robert Love <rml@tech9.net>
127- Make work without a build root
128- Correctly install the right files
129- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
130- Put some prereqs in
8634e6d1 131- Install the hotplug symlink to udev
bbab56ba 132
3660f0b8
PM
133* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
134- Initial spec file for udev-0.2.