]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] DEVNODE -> DEVNAME transition fixes
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
0c675896
GKH
14# if we want to enable debugging support in udev. If it is enabled, lots of
15# stuff will get sent to the debug syslog.
16# 0 - debugging disabled
17# 1 - debugging enabled
18%define debug 0
19
b658bc09 20# if we want to build the DBUS "extra" package or not
6fb7313b
GKH
21# 0 - no DBUS support
22# 1 - DBUS support
23%define dbus 0
24
b658bc09
GKH
25# if we want to build the SELinux "extra" package or not
26# 0 - no SELinux support
27# 1 - SELinux support
28%define selinux 0
29
ca8e992c
GKH
30# if we want to build the scsi_id "extra" package or not
31# 0 - do not build the package
32# 1 - build it
33%define scsi_id 1
34
3660f0b8
PM
35Summary: A userspace implementation of devfs
36Name: udev
1321258a 37Version: 024
3660f0b8
PM
38Release: 1
39License: GPL
40Group: Utilities/System
41Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42ExclusiveOS: Linux
e0929206 43Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 44URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 45BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 46Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
47
48%description
49udev is a implementation of devfs in userspace using sysfs and
22120496 50/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
51
52%prep
bbab56ba 53%setup -q
3660f0b8
PM
54
55%build
0c675896
GKH
56make CC="gcc $RPM_OPT_FLAGS" \
57%if %{klibc}
58 USE_KLIBC=true \
59%endif
05230184
GKH
60%if %{log}
61 USE_LOG=true \
1659326d
GKH
62%else
63 USE_LOG=false \
05230184 64%endif
0c675896
GKH
65%if %{debug}
66 DEBUG=true \
1659326d
GKH
67%else
68 DEBUG=false \
0c675896 69%endif
ca8e992c
GKH
70 EXTRAS=" \
71%if %{scsi_id}
72 extras/scsi_id \
73%endif
6fb7313b
GKH
74%if %{dbus}
75 extras/dbus \
76%endif
b658bc09
GKH
77%if %{selinux}
78 extras/selinux \
79%endif
ca8e992c 80"
d83a9b89 81
3660f0b8 82%install
5bfabc59 83make DESTDIR=$RPM_BUILD_ROOT install \
ca8e992c
GKH
84 EXTRAS=" \
85%if %{scsi_id}
86 extras/scsi_id \
87%endif
6fb7313b
GKH
88%if %{dbus}
89 extras/dbus \
90%endif
b658bc09
GKH
91%if %{selinux}
92 extras/selinux \
93%endif
ca8e992c 94"
e68582be 95
316c5150 96%post
97/sbin/chkconfig --add udev
98
600ee7f7 99%postun
100if [ $1 = 0 ]; then
101 /sbin/chkconfig --del udev
102fi
103
3660f0b8 104%clean
bbab56ba 105rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
106
107%files
ee156981 108%defattr(-,root,root)
824e6011 109%doc COPYING README TODO ChangeLog HOWTO* docs/*
110%doc etc/udev/udev.rules.{examples,gentoo,redhat}
111%doc etc/udev/udev.permissions.{gentoo,redhat}
bbab56ba 112%attr(755,root,root) /sbin/udev
0d1956de 113%attr(755,root,root) /usr/bin/udevinfo
d83a9b89
GKH
114%attr(755,root,root) /sbin/udevsend
115%attr(755,root,root) /sbin/udevd
d0dede8f 116%attr(755,root,root) /usr/bin/udevtest
1f63fbdd 117%attr(755,root,root) /sbin/udevstart
e68582be
GKH
118%attr(755,root,root) %dir /udev/
119%attr(755,root,root) %dir /etc/udev/
1b1dbc47 120%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
121%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
122%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
8634e6d1 123%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 124%attr(755,root,root) /etc/init.d/udev
567f6d14 125%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3660f0b8 126
ca8e992c
GKH
127%if %{dbus}
128 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
129%endif
130
131%if %{scsi_id}
132 %attr(755,root,root) /sbin/scsi_id
133 %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
134 %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
135%endif
136
3660f0b8 137%changelog
6fb7313b 138* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
b658bc09 139- change the way dbus and selinux support is built (now an extra)
6fb7313b 140
1f63fbdd
GKH
141* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
142- added udevstart to the list of files installed
0d1956de 143- udevinfo is now in /usr/bin not /sbin
1f63fbdd 144
7eb136ad
GKH
145* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
146- added ability to build with SELinux support
147
ca8e992c
GKH
148* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
149- add some more files to the documentation directory
150- add ability to build scsi_id and make it the default
151
e68582be
GKH
152* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
153- fix up udevd build, as it's no longer needed to be build seperatly
154- add udevtest to list of files
155- more Red Hat sync ups.
156
1659326d
GKH
157* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
158- add some changes from the latest Fedora udev release.
159
d83a9b89
GKH
160* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
161- add udevsend, and udevd to the files
162- add ability to build udevd with glibc after the rest is build with klibc
163
da1cc7cc 164* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 165- added udevinfo to rpm
8fc34188 166- added URL to spec file
567f6d14 167- added udevinfo's man page
da1cc7cc 168
e64280b8 169* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
170- add defines to choose the init script (Redhat or LSB)
171
316c5150 172* Tue Dec 16 2003 Robert Love <rml@ximian.com>
173- install the initscript and run chkconfig on it
174
e8baccca
GKH
175* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
176- changes due to config file name changes
177
bbab56ba
RL
178* Fri Oct 17 2003 Robert Love <rml@tech9.net>
179- Make work without a build root
180- Correctly install the right files
181- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
182- Put some prereqs in
8634e6d1 183- Install the hotplug symlink to udev
bbab56ba 184
3660f0b8
PM
185* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
186- Initial spec file for udev-0.2.