]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] remove USE_DBUS and USE_SELINUX flags from the README as they are no longer...
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
8481f8ce
GKH
14# if we want to build SELinux support in or not.
15# 0 - no SELinux support
16# 1 - SELinux support
e729cb0b 17%define selinux 0
8481f8ce 18
0c675896
GKH
19# if we want to enable debugging support in udev. If it is enabled, lots of
20# stuff will get sent to the debug syslog.
21# 0 - debugging disabled
22# 1 - debugging enabled
23%define debug 0
24
6fb7313b
GKH
25# if we want to build the DBUS "extra package or not
26# 0 - no DBUS support
27# 1 - DBUS support
28%define dbus 0
29
ca8e992c
GKH
30# if we want to build the scsi_id "extra" package or not
31# 0 - do not build the package
32# 1 - build it
33%define scsi_id 1
34
3660f0b8
PM
35Summary: A userspace implementation of devfs
36Name: udev
fdcfcec7 37Version: 022_bk
3660f0b8
PM
38Release: 1
39License: GPL
40Group: Utilities/System
41Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42ExclusiveOS: Linux
e0929206 43Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 44URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 45BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 46Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
47
48%description
49udev is a implementation of devfs in userspace using sysfs and
22120496 50/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
51
52%prep
bbab56ba 53%setup -q
3660f0b8
PM
54
55%build
0c675896
GKH
56make CC="gcc $RPM_OPT_FLAGS" \
57%if %{klibc}
58 USE_KLIBC=true \
59%endif
05230184
GKH
60%if %{log}
61 USE_LOG=true \
1659326d
GKH
62%else
63 USE_LOG=false \
05230184 64%endif
8481f8ce
GKH
65%if %{selinux}
66 USE_SELINUX=true \
67%else
68 USE_SELINUX=false \
69%endif
0c675896
GKH
70%if %{debug}
71 DEBUG=true \
1659326d
GKH
72%else
73 DEBUG=false \
0c675896 74%endif
ca8e992c
GKH
75 EXTRAS=" \
76%if %{scsi_id}
77 extras/scsi_id \
78%endif
6fb7313b
GKH
79%if %{dbus}
80 extras/dbus \
81%endif
ca8e992c 82"
d83a9b89 83
3660f0b8 84%install
5bfabc59 85make DESTDIR=$RPM_BUILD_ROOT install \
8481f8ce
GKH
86%if %{selinux}
87 USE_SELINUX=true \
88%else
89 USE_SELINUX=false \
e64280b8 90%endif
ca8e992c
GKH
91 EXTRAS=" \
92%if %{scsi_id}
93 extras/scsi_id \
94%endif
6fb7313b
GKH
95%if %{dbus}
96 extras/dbus \
97%endif
ca8e992c 98"
e68582be 99
316c5150 100%post
101/sbin/chkconfig --add udev
102
600ee7f7 103%postun
104if [ $1 = 0 ]; then
105 /sbin/chkconfig --del udev
106fi
107
3660f0b8 108%clean
bbab56ba 109rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
110
111%files
ee156981 112%defattr(-,root,root)
824e6011 113%doc COPYING README TODO ChangeLog HOWTO* docs/*
114%doc etc/udev/udev.rules.{examples,gentoo,redhat}
115%doc etc/udev/udev.permissions.{gentoo,redhat}
bbab56ba 116%attr(755,root,root) /sbin/udev
0d1956de 117%attr(755,root,root) /usr/bin/udevinfo
d83a9b89
GKH
118%attr(755,root,root) /sbin/udevsend
119%attr(755,root,root) /sbin/udevd
e68582be 120%attr(755,root,root) /sbin/udevtest
1f63fbdd 121%attr(755,root,root) /sbin/udevstart
e68582be
GKH
122%attr(755,root,root) %dir /udev/
123%attr(755,root,root) %dir /etc/udev/
1b1dbc47 124%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
125%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
126%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
8634e6d1 127%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 128%attr(755,root,root) /etc/init.d/udev
567f6d14 129%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3660f0b8 130
ca8e992c
GKH
131%if %{dbus}
132 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
133%endif
134
135%if %{scsi_id}
136 %attr(755,root,root) /sbin/scsi_id
137 %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
138 %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
139%endif
140
3660f0b8 141%changelog
6fb7313b
GKH
142* Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
143- change the way dbus support is built (now an extra)
144
1f63fbdd
GKH
145* Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
146- added udevstart to the list of files installed
0d1956de 147- udevinfo is now in /usr/bin not /sbin
1f63fbdd 148
7eb136ad
GKH
149* Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
150- added ability to build with SELinux support
151
ca8e992c
GKH
152* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
153- add some more files to the documentation directory
154- add ability to build scsi_id and make it the default
155
e68582be
GKH
156* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
157- fix up udevd build, as it's no longer needed to be build seperatly
158- add udevtest to list of files
159- more Red Hat sync ups.
160
1659326d
GKH
161* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
162- add some changes from the latest Fedora udev release.
163
d83a9b89
GKH
164* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
165- add udevsend, and udevd to the files
166- add ability to build udevd with glibc after the rest is build with klibc
167
da1cc7cc 168* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 169- added udevinfo to rpm
8fc34188 170- added URL to spec file
567f6d14 171- added udevinfo's man page
da1cc7cc 172
e64280b8 173* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
174- add defines to choose the init script (Redhat or LSB)
175
316c5150 176* Tue Dec 16 2003 Robert Love <rml@ximian.com>
177- install the initscript and run chkconfig on it
178
e8baccca
GKH
179* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
180- changes due to config file name changes
181
bbab56ba
RL
182* Fri Oct 17 2003 Robert Love <rml@tech9.net>
183- Make work without a build root
184- Correctly install the right files
185- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
186- Put some prereqs in
8634e6d1 187- Install the hotplug symlink to udev
bbab56ba 188
3660f0b8
PM
189* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
190- Initial spec file for udev-0.2.