]> git.ipfire.org Git - thirdparty/pdns.git/blob - builder-support/specs/pdns-recursor.spec
Merge pull request #10010 from omoerbeek/check-time_t-size
[thirdparty/pdns.git] / builder-support / specs / pdns-recursor.spec
1 Name: pdns-recursor
2 Version: %{getenv:BUILDER_RPM_VERSION}
3 Release: %{getenv:BUILDER_RPM_RELEASE}%{?dist}
4 Summary: Modern, advanced and high performance recursing/non authoritative name server
5 Group: System Environment/Daemons
6 License: GPLv2
7 URL: https://powerdns.com
8 Source0: %{name}-%{getenv:BUILDER_VERSION}.tar.bz2
9
10 Provides: powerdns-recursor = %{version}-%{release}
11
12 BuildRequires: boost-devel
13 BuildRequires: libcap-devel
14 BuildRequires: systemd
15 BuildRequires: systemd-devel
16 BuildRequires: openssl-devel
17 BuildRequires: net-snmp-devel
18 BuildRequires: libsodium-devel
19 BuildRequires: fstrm-devel
20
21 %ifarch aarch64
22 BuildRequires: lua-devel
23 %define lua_implementation lua
24 %else
25 BuildRequires: luajit-devel
26 %define lua_implementation luajit
27 %endif
28
29 %ifarch ppc64 ppc64le
30 BuildRequires: libatomic
31 %endif
32
33 Requires(pre): shadow-utils
34 %systemd_requires
35
36 %description
37 PowerDNS Recursor is a non authoritative/recursing DNS server. Use this
38 package if you need a dns cache for your network.
39
40
41 %prep
42 %autosetup -p1 -n %{name}-%{getenv:BUILDER_VERSION}
43
44 %build
45 %configure \
46 --enable-option-checking=fatal \
47 --sysconfdir=%{_sysconfdir}/%{name} \
48 --with-libsodium \
49 --with-net-snmp \
50 --disable-silent-rules \
51 --disable-static \
52 --enable-unit-tests \
53 --enable-dnstap \
54 --with-libcap \
55 --with-lua=%{lua_implementation} \
56 --enable-systemd --with-systemd=%{_unitdir}
57
58 make %{?_smp_mflags}
59
60 %check
61 make %{?_smp_mflags} check || (cat test-suite.log && false)
62
63 %install
64 make install DESTDIR=%{buildroot}
65
66 %{__mv} %{buildroot}%{_sysconfdir}/%{name}/recursor.conf{-dist,}
67
68 # change user and group to pdns-recursor
69 sed -i \
70 -e 's/# setuid=/setuid=pdns-recursor/' \
71 -e 's/# setgid=/setgid=pdns-recursor/' \
72 %{buildroot}%{_sysconfdir}/%{name}/recursor.conf
73
74 %pre
75 getent group pdns-recursor > /dev/null || groupadd -r pdns-recursor
76 getent passwd pdns-recursor > /dev/null || \
77 useradd -r -g pdns-recursor -d / -s /sbin/nologin \
78 -c "PowerDNS Recursor user" pdns-recursor
79 exit 0
80
81 %post
82 systemctl daemon-reload ||:
83 %systemd_post %{name}.service
84
85 %preun
86 %systemd_preun %{name}.service
87
88 %postun
89 %systemd_postun_with_restart pdns-recursor.service
90
91 %files
92 %{_bindir}/rec_control
93 %{_sbindir}/pdns_recursor
94 %{_mandir}/man1/pdns_recursor.1.gz
95 %{_mandir}/man1/rec_control.1.gz
96 %{_unitdir}/pdns-recursor.service
97 %{_unitdir}/pdns-recursor@.service
98 %dir %{_sysconfdir}/%{name}
99 %config(noreplace) %{_sysconfdir}/%{name}/recursor.conf
100 %doc README