]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/blob - meta/recipes-devtools/build-compare/build-compare_git.bb
build-compare: derive PV from SRCPV
[thirdparty/openembedded/openembedded-core.git] / meta / recipes-devtools / build-compare / build-compare_git.bb
1 SUMMARY = "Build Result Compare Script"
2 DESCRIPTION = "This package contains scripts to find out if the build result\
3 differs to a former build."
4 HOMEPAGE = "https://github.com/openSUSE/build-compare"
5 LICENSE = "GPLv2"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7
8 SRC_URI = "git://github.com/openSUSE/build-compare.git \
9 file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1 \
10 file://Ignore-DWARF-sections.patch;striplevel=1 \
11 file://0001-Add-support-for-deb-and-ipk-packaging.patch \
12 file://functions.sh-remove-space-at-head.patch \
13 file://functions.sh-run-rpm-once-to-make-it-faster.patch \
14 file://pkg-diff.sh-check-for-fifo-named-pipe.patch \
15 file://pkg-diff.sh-check_single_file-return-at-once-when-sa.patch \
16 file://pkg-diff.sh-remove-space-in-the-end-for-ftype.patch \
17 file://functions.sh-improve-deb-and-ipk-checking.patch \
18 "
19
20 SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a"
21 PV = "git+${SRCPV}"
22
23 S = "${WORKDIR}/git"
24
25 BBCLASSEXTEND += "native nativesdk"
26
27 do_install() {
28 install -d ${D}/${bindir}
29 install -m 755 functions.sh ${D}/${bindir}
30 install -m 755 pkg-diff.sh ${D}/${bindir}
31 install -m 755 same-build-result.sh ${D}/${bindir}
32 install -m 755 srpm-check.sh ${D}/${bindir}
33 }
34
35 RDEPENDS_${PN} += "bash"