]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/blob - meta/recipes-extended/xdg-utils/xdg-utils_1.1.3.bb
d95bcccd2a57814ca45d838b7a41e03a72f43589
[thirdparty/openembedded/openembedded-core.git] / meta / recipes-extended / xdg-utils / xdg-utils_1.1.3.bb
1 SUMMARY = "Basic desktop integration functions"
2 HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xdg-utils/"
3 DESCRIPTION = "The xdg-utils package is a set of simple scripts that provide basic \
4 desktop integration functions for any Free Desktop, such as Linux. \
5 They are intended to provide a set of defacto standards. \
6 The following scripts are provided at this time: \
7 xdg-desktop-icon \
8 xdg-desktop-menu \
9 xdg-email \
10 xdg-icon-resource \
11 xdg-mime \
12 xdg-open \
13 xdg-screensaver \
14 xdg-terminal \
15 "
16
17 LICENSE = "MIT"
18 LIC_FILES_CHKSUM = "file://LICENSE;md5=a5367a90934098d6b05af3b746405014"
19
20 SRC_URI = "https://portland.freedesktop.org/download/${BPN}-${PV}.tar.gz \
21 file://0001-Reinstate-xdg-terminal.patch \
22 file://0001-Don-t-build-the-in-script-manual.patch \
23 file://1f199813e0eb0246f63b54e9e154970e609575af.patch \
24 file://CVE-2020-27748.patch \
25 "
26
27 SRC_URI[md5sum] = "902042508b626027a3709d105f0b63ff"
28 SRC_URI[sha256sum] = "d798b08af8a8e2063ddde6c9fa3398ca81484f27dec642c5627ffcaa0d4051d9"
29
30 UPSTREAM_CHECK_REGEX = "xdg-utils-(?P<pver>((\d+[\.\-_]*)+)((rc|alpha|beta)\d+)?)\.(tar\.gz|tgz)"
31
32 # Needs brokensep as this doesn't use automake
33 inherit autotools-brokensep features_check
34
35 # The xprop requires x11 in DISTRO_FEATURES
36 REQUIRED_DISTRO_FEATURES = "x11"
37
38 DEPENDS = "xmlto-native libxslt-native"
39 RDEPENDS:${PN} += "xprop"