1 # if we want to build against the included version of klibc or not.
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
8 # if we want to have logging support in or not.
9 # 0 - no logging support
11 # Note, it is not recommend if you use klibc to enable logging.
14 # if we want to enable debugging support in udev. If it is enabled, lots of
15 # stuff will get sent to the debug syslog.
16 # 0 - debugging disabled
17 # 1 - debugging enabled
20 # if we want to build the scsi_id "extra" package or not
21 # 0 - do not build the package
25 # if we want to build the volume_id "extra" package or not
26 # 0 - do not build the package
30 Summary: A userspace implementation of devfs
35 Group: Utilities
/System
36 Source: ftp
://ftp.kernel.org
/pub
/linux
/utils
/kernel
/hotplug
/%{name}-%{version}.tar.gz
38 Vendor: Greg Kroah
-Hartman
<greg@kroah.com
>
39 URL : kernel.org
/pub
/linux
/utils
/kernel
/hotplug
/
40 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
41 Prereq
: /bin
/sh
, fileutils
, hotplug
44 udev is a implementation of devfs
in userspace using sysfs and
45 /sbin
/hotplug. It requires a
2.6 kernel to run properly.
51 make CC
="gcc $RPM_OPT_FLAGS" \
75 rm -rf $RPM_BUILD_ROOT
76 make DESTDIR
=$RPM_BUILD_ROOT
install \
87 /sbin
/chkconfig
--add udev
91 /sbin
/chkconfig
--del udev
95 rm -rf $RPM_BUILD_ROOT
99 %doc COPYING README TODO ChangeLog HOWTO
* docs
/*
100 %doc etc
/udev
/udev.rules.
{examples
,gentoo
,redhat
}
101 %doc etc
/udev
/udev.permissions.
{gentoo
,redhat
}
102 %attr(755,root
,root
) /sbin
/udev
103 %attr(755,root
,root
) /usr
/bin
/udevinfo
104 %attr(755,root
,root
) /sbin
/udevsend
105 %attr(755,root
,root
) /sbin
/udevd
106 %attr(755,root
,root
) /usr
/bin
/udevtest
107 %attr(755,root
,root
) /sbin
/udevstart
108 %attr(755,root
,root
) %dir /udev
/
109 %attr(755,root
,root
) %dir /etc
/udev
/
110 %config(noreplace
) %attr(0644,root
,root
) /etc
/udev
/udev.conf
111 %attr(755,root
,root
) %dir /etc
/udev
/rules.d
/
112 %attr(755,root
,root
) %dir /etc
/udev
/permissions.d
/
113 %config(noreplace
) %attr(0644,root
,root
) /etc
/udev
/rules.d
/50-udev.rules
114 %config(noreplace
) %attr(0644,root
,root
) /etc
/udev
/permissions.d
/50-udev.permissions
115 %attr(-,root
,root
) /etc
/hotplug.d
/default
/udev.hotplug
116 %attr(755,root
,root
) /etc
/init.d
/udev
117 %attr(0644,root
,root
) %{_mandir}/man8
/udev
*.8*
118 %attr(755,root
,root
) %dir /etc
/dev.d
/
119 %attr(755,root
,root
) %dir /etc
/dev.d
/net
/
120 %attr(0755,root
,root
) /etc
/dev.d
/net
/hotplug.dev
123 %attr(755,root
,root
) /sbin
/scsi_id
124 %config(noreplace
) %attr(0644,root
,root
) /etc
/scsi_id.config
125 %attr(0644,root
,root
) %{_mandir}/man8
/scsi_id
*.8*
128 %attr(755,root
,root
) /sbin
/udev_volume_id
132 * Fri May
14 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
133 - remove dbus and selinux stuff from here
134 - added volume_id option
136 * Wed Mar
24 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
137 - change the way dbus and selinux support is built
(now an extra
)
139 * Tue Mar
2 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
140 - added udevstart to the list of files installed
141 - udevinfo is now
in /usr
/bin not
/sbin
143 * Fri Feb
27 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
144 - added ability to build with SELinux support
146 * Thu Feb
19 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
147 - add some more files to the documentation directory
148 - add ability to build scsi_id and
make it the default
150 * Mon Feb
16 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
151 - fix up udevd build
, as it's no longer needed to be build seperatly
152 - add udevtest to list of files
153 - more Red Hat sync ups.
155 * Thu Feb
12 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
156 - add some changes from the latest Fedora udev release.
158 * Mon Feb
2 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
159 - add udevsend
, and udevd to the files
160 - add ability to build udevd with glibc after the rest is build with klibc
162 * Mon Jan
26 2004 Greg Kroah
-Hartman
<greg@kroah.com
>
163 - added udevinfo to rpm
164 - added
URL to spec file
165 - added udevinfo's man page
167 * Mon Jan
05 2004 Rolf Eike Beer
<eike
-hotplug@sf
-tec.de
>
168 - add defines to choose the init script
(Redhat or LSB
)
170 * Tue Dec
16 2003 Robert Love
<rml@ximian.com
>
171 - install the initscript and run chkconfig on it
173 * Tue Nov
2 2003 Greg Kroah
-Hartman
<greg@kroah.com
>
174 - changes due to config file name changes
176 * Fri Oct
17 2003 Robert Love
<rml@tech9.net
>
177 - Make work without a build root
178 - Correctly
install the right files
179 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
180 - Put some prereqs
in
181 - Install the hotplug symlink to udev
183 * Mon Jul
28 2003 Paul Mundt
<lethal@linux
-sh.org
>
184 - Initial spec file
for udev
-0.2.