]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
python3-cryptography-vectors: from meta-python
authorTim Orling <tim.orling@konsulko.com>
Sat, 12 Mar 2022 21:00:50 +0000 (13:00 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2022 08:44:46 +0000 (08:44 +0000)
Dependency for python3-cryptography ptest.

This recipe needs to be kept in lock-step with the version of
python3-cryptography.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
new file mode 100644 (file)
index 0000000..b9e6b81
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "Test vectors for the cryptography package."
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
+                    file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
+                    file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
+
+# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
+#       Upgrade both recipes at the same time
+
+SRC_URI[sha256sum] = "fc8490afd5424342b868215435bd174dcd76ab396b4ea9435498be5721dcd598"
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+    ${PYTHON_PN}-cryptography \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = ""