]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
eglibc: Add patch to add sys/resource.h to wait.h
authorSaul Wold <sgw@linux.intel.com>
Wed, 25 Jul 2012 21:34:27 +0000 (14:34 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Jul 2012 13:07:22 +0000 (14:07 +0100)
This is needed for the older kernel perf tools to build correctly, as
noted in the patch new perf tools have sys/resource.h included directly.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch [new file with mode: 0644]
meta/recipes-core/eglibc/eglibc_2.16.bb

diff --git a/meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch b/meta/recipes-core/eglibc/eglibc-2.16/add_resource_h_to_wait_h.patch
new file mode 100644 (file)
index 0000000..f5023c0
--- /dev/null
@@ -0,0 +1,20 @@
+The older versions of perf still require sys/resource.h to be 
+present in this header, the newer version of perf in 3.2 and
+beyond directly include sys/resource.h
+
+Upstream-Status: Inapproriate [older kernel/perf specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: libc/posix/sys/wait.h
+===================================================================
+--- libc.orig/posix/sys/wait.h
++++ libc/posix/sys/wait.h
+@@ -28,6 +28,7 @@
+ __BEGIN_DECLS
+ #include <signal.h>
++#include <sys/resource.h>
+ /* These macros could also be defined in <stdlib.h>.  */
+ #if !defined _STDLIB_H || (!defined __USE_XOPEN && !defined __USE_XOPEN2K8)
index 8fa5451dac2108902082832b4c250e59380848de..f9a8f6da680c3f44c58e4ebf09a46bebcd97b100 100644 (file)
@@ -3,7 +3,7 @@ require eglibc.inc
 SRCREV = "19383"
 
 DEPENDS += "gperf-native"
-PR = "r3"
+PR = "r4"
 PR_append = "+svnr${SRCPV}"
 
 EGLIBC_BRANCH="eglibc-2_16"
@@ -24,6 +24,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
            file://rpc-bootstrap.patch \
            file://e500-math_private.patch \
            file://fileops-without-wchar-io.patch \
+           file://add_resource_h_to_wait_h.patch \
           "
 LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
       file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \