]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
kernel-devsrc: depend on python3-core instead of python3
authorbkylerussell@gmail.com <bkylerussell@gmail.com>
Tue, 11 Apr 2023 17:36:16 +0000 (13:36 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Apr 2023 10:55:41 +0000 (11:55 +0100)
Avoids pulling in potential GPLv3 packages through python3-misc catch-all.

python3-core is the intended minimal RDEPENDS for packages requiring python3
support.  Other python3 module dependencies should be listed explicitly.

Signed-off-by: Kyle Russell <bkylerussell@gmail.com>
Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
meta/recipes-kernel/linux/kernel-devsrc.bb

index b4ea5f756aef5f923cc74f3415fed281546f190b..6764598d488323881ed4181bee606ace0a9df2c9 100644 (file)
@@ -377,7 +377,7 @@ do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
 FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
 FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
 
-RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
+RDEPENDS:${PN} = "bc python3-core flex bison ${TCLIBC}-utils"
 # 4.15+ needs these next two RDEPENDS
 RDEPENDS:${PN} += "openssl-dev util-linux"
 # and x86 needs a bit more for 4.15+