]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
mdadm: Disable 10ddf-fail-spare and 10ddf-fail-stop-readd testcases
authorKhem Raj <raj.khem@gmail.com>
Fri, 12 Jan 2024 22:04:23 +0000 (14:04 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 15 Jan 2024 21:42:05 +0000 (21:42 +0000)
This always fails in my CI setup. There are some others which fail
intermittently however, this one is deterministic and fails always e.g.

    AssertionError:- [1/1]
    Failed ptests:
    {'mdadm': ['/usr/lib/mdadm/ptest/tests/10ddf-fail-spareFAILED_-_see_/usr/lib/mdadm/ptest/logs/10ddf-fail-spare.log_and_/usr/lib/mdadm/ptest/lo

Mark them broken for now.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/mdadm/mdadm_4.2.bb

index c66a89677f6ce8300229dcb231e22a00d72e1a46..6f8724939839d07f0930ba2f4970ecbc03c5b166 100644 (file)
@@ -110,6 +110,8 @@ do_install_ptest() {
        echo "intermittent failure on autobuilder" > ${D}${PTEST_PATH}/tests/19raid6check.broken
        echo "intermittent failure on autobuilder" > ${D}${PTEST_PATH}/tests/20raid5journal.broken
        echo "intermittent failure on autobuilder" > ${D}${PTEST_PATH}/tests/21raid5cache.broken
+       echo "intermittent failure on autobuilder" > ${D}${PTEST_PATH}/tests/10ddf-fail-spare.broken
+       echo "intermittent failure on autobuilder" > ${D}${PTEST_PATH}/tests/10ddf-fail-stop-readd.broken
 }
 
 RDEPENDS:${PN} += "bash"