]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
python3-docutils: Rename utilities to their canonical names
authorKhem Raj <raj.khem@gmail.com>
Mon, 2 Oct 2023 01:13:50 +0000 (18:13 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Oct 2023 22:54:51 +0000 (23:54 +0100)
Packages which use the utilities usually call/search for these tools
without .py extension e.g. kernel-selftest and fails to find the tools
if they are having .py extension.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-docutils_0.20.1.bb

index 65ca55e07bf34666fe624af424e5655dc7e1fa2f..6038732cc4f2c9b0ab32f2271b5effe7f3294a59 100644 (file)
@@ -8,4 +8,13 @@ SRC_URI[sha256sum] = "f08a4e276c3a1583a86dce3e34aba3fe04d02bba2dd51ed16106244e8a
 
 inherit pypi setuptools3
 
+do_install:append() {
+    for f in rst2html rst2html4 rst2html5 rst2latex rst2man \
+                  rst2odt rst2odt_prepstyles rst2pseudoxml rst2s5 rst2xetex rst2xml \
+                  rstpep2html
+    do
+        mv ${D}${bindir}/$f.py ${D}${bindir}/$f;
+    done
+}
+
 BBCLASSEXTEND = "native nativesdk"