]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
glib-2.0: Drop allow /run/media for root patch
authorAlex Kiernan <alex.kiernan@gmail.com>
Sun, 23 Sep 2018 17:21:00 +0000 (17:21 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Sep 2018 22:15:42 +0000 (23:15 +0100)
Upstream implemented an equivalent fix in:

c672fcc0a8d6 ("gunixmounts: Allow root to display mounts under /run/media/$username")

As a result, this change is completely broken when running as root, as
user_name is unitialised when testing strcmp(user_name, "root") so just
segfaults.

Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0/allow-run-media-sdX-drive-mount-if-username-root.patch [deleted file]
meta/recipes-core/glib-2.0/glib-2.0_2.58.0.bb

diff --git a/meta/recipes-core/glib-2.0/glib-2.0/allow-run-media-sdX-drive-mount-if-username-root.patch b/meta/recipes-core/glib-2.0/glib-2.0/allow-run-media-sdX-drive-mount-if-username-root.patch
deleted file mode 100644 (file)
index 3040479..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 66e5fd5e870a2de04ec0f0c5dbfa23db496bad43 Mon Sep 17 00:00:00 2001
-From: Marius Avram <marius.avram@intel.com>
-Date: Wed, 27 Aug 2014 12:10:41 +0300
-Subject: [PATCH] Allow /run/media/sdX drive mount if username root
-
-In case that the username logged in the system is root
-the drives are directly mounted in /run/media/sdX and
-not /run/media/<username>/sdX as the function
-g_unix_mount_guess_should_display() expects.
-
-Without this change USB stick mounts are not accesible from
-graphical applications such as the File Manager (pcmanfm).
-
-Upstream-Status: Inappropriate
-
-Signed-off-by: Marius Avram <marius.avram@intel.com>
-
----
- gio/gunixmounts.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/gio/gunixmounts.c b/gio/gunixmounts.c
-index 355329c..6467fc5 100644
---- a/gio/gunixmounts.c
-+++ b/gio/gunixmounts.c
-@@ -2745,6 +2745,11 @@ g_unix_mount_guess_should_display (GUnixMountEntry *mount_entry)
-             is_in_runtime_dir = TRUE;
-         }
-+      /* Allow no username in path in /run/media if current user is root */
-+      if (strcmp(user_name, "root") == 0 &&
-+          strncmp (mount_path, "/run/media/", sizeof("run/media")) == 0)
-+        is_in_runtime_dir = TRUE;
-+
-       if (is_in_runtime_dir || g_str_has_prefix (mount_path, "/media/"))
-         {
-           char *path;
index 92c7997a2724d4553e2cb67fb1f6c49341350ccd..6ebf1d2599440b5d5b8b6c32852c9beafd04e151 100644 (file)
@@ -8,7 +8,6 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
            file://configure-libtool.patch \
            file://run-ptest \
            file://uclibc_musl_translation.patch \
-           file://allow-run-media-sdX-drive-mount-if-username-root.patch \
            file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
            file://Enable-more-tests-while-cross-compiling.patch \
            file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \