]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
systemd: Ensure uid/gid ranges are set deterministically
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 19 Dec 2020 11:20:31 +0000 (11:20 +0000)
committerSteve Sakoman <steve@sakoman.com>
Mon, 7 Mar 2022 17:05:18 +0000 (07:05 -1000)
meson.build will fall back to greping /etc/login.defs for values of these
if they're not set. Different distros set them (Centos 7/8 does, Ubuntu
does not) so output was not deterministic. Avoid this by setting to the
default values. We now match the vaules from login.defs from shadow.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 77a6ac0ac266d71e4fe67fd332662081f30cd7bf)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-core/systemd/systemd_244.5.bb

index 66446e2a7c4f104f5efbc73cd3007be875185e50..a648272bc03dc23107e1f25a9fb346f6d535ad8e 100644 (file)
@@ -216,6 +216,8 @@ EXTRA_OEMESON += "-Dnobody-user=nobody \
                   -Drootlibdir=${rootlibdir} \
                   -Drootprefix=${rootprefix} \
                   -Ddefault-locale=C \
+                  -Dsystem-uid-max=999 \
+                  -Dsystem-gid-max=999 \
                   "
 
 # Hardcode target binary paths to avoid using paths from sysroot