]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/commitdiff
python3-pytest-subtests: move from meta-python
authorTim Orling <tim.orling@konsulko.com>
Sat, 12 Mar 2022 20:59:18 +0000 (12:59 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2022 08:44:46 +0000 (08:44 +0000)
Dependency for python3-cryptography ptest.

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb b/meta/recipes-devtools/python/python3-pytest-subtests_0.6.0.bb
new file mode 100644 (file)
index 0000000..5e4847b
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "unittest subTest() support and subtests fixture."
+DESCRIPTION = "Adds support for TestCase.subTest.\
+New subtests fixture, providing similar functionality for pure pytest tests."
+HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
+BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
+
+SRC_URI[sha256sum] = "3ebd306a8dcf75133f1742f288c82f36426ebcf8a132d4ee89782d20e84fc13a"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"