]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
gcc_7.1.bb: disable thumb on armv5t
authorKhem Raj <raj.khem@gmail.com>
Sat, 10 Jun 2017 18:34:24 +0000 (11:34 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 14 Jun 2017 09:23:22 +0000 (10:23 +0100)
It results in same link errors like armv4t

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-devtools/gcc/gcc_7.1.bb

index 2c618dfb93610769684cce4c6e0dd02791b6aa2e..ab208e7026399f1438d1a3a20bf2c5369a84d38f 100644 (file)
@@ -1,9 +1,10 @@
 require recipes-devtools/gcc/gcc-${PV}.inc
 require gcc-target.inc
 
-# Building with thumb enabled on armv4t fails with
+# Building with thumb enabled on armv4t armv5t fails with
 # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
 # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
 ARM_INSTRUCTION_SET_armv4 = "arm"
+ARM_INSTRUCTION_SET_armv5 = "arm"
 
 BBCLASSEXTEND = "nativesdk"