]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
tcl: enable ptest support
authorChong Lu <Chong.Lu@windriver.com>
Wed, 8 Jan 2014 08:49:56 +0000 (16:49 +0800)
committerSaul Wold <sgw@linux.intel.com>
Thu, 9 Jan 2014 06:54:55 +0000 (22:54 -0800)
Install tcl test suite and run it as ptest.

Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/tcltk/tcl/run-ptest [new file with mode: 0644]
meta/recipes-devtools/tcltk/tcl_8.6.1.bb

diff --git a/meta/recipes-devtools/tcltk/tcl/run-ptest b/meta/recipes-devtools/tcltk/tcl/run-ptest
new file mode 100644 (file)
index 0000000..a5d6548
--- /dev/null
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+for i in `ls tests/*.test |awk -F/ '{print $2}'`; \
+    do TCL_LIBRARY=library ./tcltest tests/all.tcl -file $i &>$i.tmp; \
+    grep -q "^Files with failing tests:" $i.tmp; \
+    if [ $? == 0 ]; then echo "FAIL: $i"; \
+    else echo "PASS: $i"; rm -f $i.tmp; fi; \
+done
index c5eb20581b4d7cbbd4c2fb9f03e58ce58f525d01..662261b1cbf8a36da19d26589dde3cddaf1695ba 100644 (file)
@@ -20,6 +20,7 @@ SRC_URI = "${BASE_SRC_URI} \
            file://no_packages.patch \
            file://tcl-remove-hardcoded-install-path.patch \
            file://alter-includedir.patch \
+           file://run-ptest \
           "
 SRC_URI[md5sum] = "aae4b701ee527c6e4e1a6f9c7399882e"
 SRC_URI[sha256sum] = "16ee769248e64ba1cae6b4834fcc4e4edd7470d881410e8d58f7dd1434343514"
@@ -30,7 +31,7 @@ S = "${WORKDIR}/tcl${PV}/unix"
 
 VER = "8.6.1"
 
-inherit autotools
+inherit autotools ptest
 
 DEPENDS_class-native = ""
 
@@ -79,3 +80,13 @@ RDEPENDS_${PN} += "tcl-lib"
 RDEPENDS_${PN}_class-native = ""
 
 BBCLASSEXTEND = "native"
+
+do_compile_ptest() {
+       oe_runmake tcltest
+}
+
+do_install_ptest() {
+       cp ${B}/tcltest ${D}${PTEST_PATH}
+       cp -r ${S}/../library ${D}${PTEST_PATH}
+       cp -r ${S}/../tests ${D}${PTEST_PATH}
+}