]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
pam: Fix for CVE-2024-22365
authorVijay Anusuri <vanusuri@mvista.com>
Wed, 24 Jan 2024 04:05:24 +0000 (09:35 +0530)
committerSteve Sakoman <steve@sakoman.com>
Wed, 24 Jan 2024 14:17:16 +0000 (04:17 -1000)
Upstream-Status: Backport from https://github.com/linux-pam/linux-pam/commit/031bb5a5d0d950253b68138b498dc93be69a64cb

Signed-off-by: Vijay Anusuri <vanusuri@mvista.com>
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-extended/pam/libpam/CVE-2024-22365.patch [new file with mode: 0644]
meta/recipes-extended/pam/libpam_1.3.1.bb

diff --git a/meta/recipes-extended/pam/libpam/CVE-2024-22365.patch b/meta/recipes-extended/pam/libpam/CVE-2024-22365.patch
new file mode 100644 (file)
index 0000000..33ac37b
--- /dev/null
@@ -0,0 +1,59 @@
+From 031bb5a5d0d950253b68138b498dc93be69a64cb Mon Sep 17 00:00:00 2001
+From: Matthias Gerstner <matthias.gerstner@suse.de>
+Date: Wed, 27 Dec 2023 14:01:59 +0100
+Subject: [PATCH] pam_namespace: protect_dir(): use O_DIRECTORY to prevent
+ local DoS situations
+
+Without O_DIRECTORY the path crawling logic is subject to e.g. FIFOs
+being placed in user controlled directories, causing the PAM module to
+block indefinitely during `openat()`.
+
+Pass O_DIRECTORY to cause the `openat()` to fail if the path does not
+refer to a directory.
+
+With this the check whether the final path element is a directory
+becomes unnecessary, drop it.
+
+Upstream-Status: Backport [https://github.com/linux-pam/linux-pam/commit/031bb5a5d0d950253b68138b498dc93be69a64cb]
+CVE: CVE-2024-22365
+Signed-off-by: Vijay Anusuri <vanusuri@mvista.com>
+---
+ modules/pam_namespace/pam_namespace.c | 18 +-----------------
+ 1 file changed, 1 insertion(+), 17 deletions(-)
+
+diff --git a/modules/pam_namespace/pam_namespace.c b/modules/pam_namespace/pam_namespace.c
+index 2528cff86..f72d67189 100644
+--- a/modules/pam_namespace/pam_namespace.c
++++ b/modules/pam_namespace/pam_namespace.c
+@@ -1201,7 +1201,7 @@ static int protect_dir(const char *path, mode_t mode, int do_mkdir,
+       int dfd = AT_FDCWD;
+       int dfd_next;
+       int save_errno;
+-      int flags = O_RDONLY;
++      int flags = O_RDONLY | O_DIRECTORY;
+       int rv = -1;
+       struct stat st;
+@@ -1255,22 +1255,6 @@ static int protect_dir(const char *path, mode_t mode, int do_mkdir,
+               rv = openat(dfd, dir, flags);
+       }
+-      if (rv != -1) {
+-              if (fstat(rv, &st) != 0) {
+-                      save_errno = errno;
+-                      close(rv);
+-                      rv = -1;
+-                      errno = save_errno;
+-                      goto error;
+-              }
+-              if (!S_ISDIR(st.st_mode)) {
+-                      close(rv);
+-                      errno = ENOTDIR;
+-                      rv = -1;
+-                      goto error;
+-              }
+-      }
+-
+       if (flags & O_NOFOLLOW) {
+               /* we are inside user-owned dir - protect */
+               if (protect_mount(rv, p, idata) == -1) {
index bc72afe6adb295b92c534dc4c19918e359f2ca22..527a368e2df7e3348520d5f1e9f733d03e3453a0 100644 (file)
@@ -24,6 +24,7 @@ SRC_URI = "https://github.com/linux-pam/linux-pam/releases/download/v${PV}/Linux
            file://pam-security-abstract-securetty-handling.patch \
            file://pam-unix-nullok-secure.patch \
            file://crypt_configure.patch \
+           file://CVE-2024-22365.patch \
           "
 
 SRC_URI[md5sum] = "558ff53b0fc0563ca97f79e911822165"