]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
coreutils: Ignore line-bytes.sh and no-allocate tests on musl
authorKhem Raj <raj.khem@gmail.com>
Wed, 10 Jan 2024 04:49:41 +0000 (20:49 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 12 Jan 2024 11:51:18 +0000 (11:51 +0000)
bash fails in xmalloc when running these tests. More thorough
investigation may reveal real cause, however, it seems to fail on
other musl distros as well.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/coreutils/coreutils_9.4.bb

index f210df2e697a7d279263e4f4693fb3f644ebdb76..367b0119881b5b334815f554abed742c874a717a 100644 (file)
@@ -210,4 +210,10 @@ do_install_ptest () {
     sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
 }
 
+do_install_ptest:append:libc-musl () {
+    # these tests fail due to bash on musl systems
+    # xmalloc: cannot allocate 16146 bytes
+    sed -i -e '/tests\/dd\/no-allocate.sh/d' ${D}${PTEST_PATH}/Makefile
+    sed -i -e '/tests\/split\/line-bytes.sh/d' ${D}${PTEST_PATH}/Makefile
+}
 FILES:${PN}-ptest += "${bindir}/getlimits"