]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
pkgconfig: Fix packaging issue
authorSaul Wold <sgw@linux.intel.com>
Thu, 26 Jul 2012 07:36:48 +0000 (00:36 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 27 Jul 2012 13:07:22 +0000 (14:07 +0100)
The pkg.m4 file should be packaged as part of the base package
instead of the -dev package, it had been in the base package, but
I seemed to have missed that it moved during my PACKAGES reorder,
and this caused the meta-toolchain to break

[YOCTO #1908]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/pkgconfig/pkgconfig.inc
meta/recipes-devtools/pkgconfig/pkgconfig_0.25.bb

index 00c23d7ff8328cd32b77a1869471484169ba131a..10dba04896a34299bfa6256180f9748a446df927 100644 (file)
@@ -32,4 +32,9 @@ do_configure_prepend () {
 
 BBCLASSEXTEND = "native nativesdk"
 
+# Set an empty dev package to ensure the base PN package gets
+# the pkg.m4 macros, pkgconfig does not deliver any other -dev
+# files.
+FILES_${PN}-dev = ""
 FILES_${PN} += "${datadir}/aclocal/pkg.m4"
+RREPLACES_${PN}-dev = "${PN}"
index 1d7ba49b955aeabeb8fbef3e820e2878c51bf9c7..08a3dbfc29a1bdf343affea7359e12cf903e0192 100644 (file)
@@ -1,6 +1,6 @@
 require pkgconfig.inc
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI[md5sum] = "a3270bab3f4b69b7dc6dbdacbcae9745"
 SRC_URI[sha256sum] = "3ba691ee2431f32ccb8efa131e59bf23e37f122dc66791309023ca6dcefcd10e"