]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
busybox: remove busybox-udhcpc-no_deconfig.patch
authorAlexander Kanavin <alex.kanavin@gmail.com>
Fri, 19 Apr 2024 12:19:36 +0000 (14:19 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 25 Apr 2024 09:10:12 +0000 (10:10 +0100)
The option was introduced in:
https://git.yoctoproject.org/poky/commit/?h=master&id=427472e980cd6254a5e4ef37209b327e15af259b
for the purpose of a standalone udhcpc service.

18 months later the service was removed as it was clashing with the
broader networking service, and the option isn't used
anywhere else:
https://git.yoctoproject.org/poky/commit/?h=master&id=a4b1e348484b74d055b8906413892789d3452f4a

There's a slight chance the option still survives
somewhere private, and is important in that context,
but I'd rather drop the patch so it can be maintained
where it's useful, and maybe even proposed upstream.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/busybox/busybox/busybox-udhcpc-no_deconfig.patch [deleted file]
meta/recipes-core/busybox/busybox_1.36.1.bb

diff --git a/meta/recipes-core/busybox/busybox/busybox-udhcpc-no_deconfig.patch b/meta/recipes-core/busybox/busybox/busybox-udhcpc-no_deconfig.patch
deleted file mode 100644 (file)
index 948932a..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-From 53626cd06a3ef05ed847daea802ef0aa9661caa7 Mon Sep 17 00:00:00 2001
-From: Anders Darander <anders@chargestorm.se>
-Date: Thu, 3 Nov 2011 08:51:31 +0100
-Subject: [PATCH] busybox-udhcpc-no_deconfig.patch
-
-Upstream-Status: Pending
-
-Add a new option -D to the udhcpc client that allows for
-dhcp renewal to occur without having to down the interface
-in the process.
-
-Signed-off-by: Greg Moffatt <greg.moffatt@windriver.com>
-
-Updated to latest Busybox 1.17.3
-
-Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-
-Updated to Busybox 1.18.4
-option spec is changed
-
-Signed-off-by: Qing He <qing.he@intel.com>
-
-Updated to Busybox 1.19.3
-
-Signed-off-by: Anders Darander <anders@chargestorm.se>
-
-Fixed options -b, -a and -P.
-
-Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
----
- networking/udhcp/dhcpc.c                       | 29 ++++++++++++++++------
- 1 file changed, 21 insertions(+), 8 deletions(-)
-
-Index: busybox-1.34.0/networking/udhcp/dhcpc.c
-===================================================================
---- busybox-1.34.0.orig/networking/udhcp/dhcpc.c
-+++ busybox-1.34.0/networking/udhcp/dhcpc.c
-@@ -48,6 +48,8 @@
- };
- #endif
-+/* option whether to down the interface when reconfiguring */
-+static int allow_deconfig = 1;
- /* "struct client_data_t client_data" is in bb_common_bufsiz1 */
-@@ -100,8 +102,10 @@
-       OPT_x = 1 << 16,
-       OPT_f = 1 << 17,
-       OPT_B = 1 << 18,
-+      OPT_D = 1 << 19,
- /* The rest has variable bit positions, need to be clever */
-       OPTBIT_B = 18,
-+      OPTBIT_D = 19,
-       USE_FOR_MMU(             OPTBIT_b,)
-       IF_FEATURE_UDHCPC_ARPING(OPTBIT_a,)
-       IF_FEATURE_UDHCP_PORT(   OPTBIT_P,)
-@@ -587,7 +591,8 @@
- static void d4_run_script_deconfig(void)
- {
--      d4_run_script(NULL, "deconfig");
-+      if (allow_deconfig)
-+              d4_run_script(NULL, "deconfig");
- }
- /*** Sending/receiving packets ***/
-@@ -1244,7 +1249,7 @@
-       /* Parse command line */
-       opt = getopt32long(argv, "^"
-               /* O,x: list; -T,-t,-A take numeric param */
--              "CV:F:i:np:qRr:s:T:+t:+SA:+O:*ox:*fB"
-+              "CV:F:i:np:qRr:s:T:+t:+SA:+O:*ox:*fBD"
-               USE_FOR_MMU("b")
-               IF_FEATURE_UDHCPC_ARPING("a::")
-               IF_FEATURE_UDHCP_PORT("P:")
-@@ -1361,6 +1366,10 @@
-               logmode |= LOGMODE_SYSLOG;
-       }
-+      if (opt & OPT_D) {
-+              allow_deconfig = 0;
-+      }
-+
-       /* Create pidfile */
-       write_pidfile(client_data.pidfile);
-       /* Goes to stdout (unless NOMMU) and possibly syslog */
index 06eb9eb9996bc13ccd96acbd70d437fc16a54266..373a6b7781b206748213cb89ec0c505d27f6df07 100644 (file)
@@ -2,7 +2,6 @@ require busybox.inc
 
 SRC_URI = "https://busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://0001-depmod-Ignore-.debug-directories.patch \
-           file://busybox-udhcpc-no_deconfig.patch \
            file://find-touchscreen.sh \
            file://busybox-cron \
            file://busybox-httpd \