]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
python3-more-itertools: upgrade 8.14.0 -> 9.0.0
authorTim Orling <ticotimo@gmail.com>
Wed, 2 Nov 2022 03:18:26 +0000 (20:18 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Nov 2022 07:42:06 +0000 (07:42 +0000)
https://github.com/more-itertools/more-itertools/blob/master/docs/versions.rst#900

9.0.0

* Potentially breaking changes
  - `grouper` no longer accepts an integer as its first
    argument. Previously this raised a DeprecationWarning.
  - `collate` has been removed. Use the built-in
    `heapq.merge` instead.
  - `windowed` now yields nothing when its iterable is
     empty.

* This library now advertises support for Python 3.7+.

* New functions
  - `constrained_batches`
  - `batched` (from the Python itertools docs)
  - `polynomial_from_roots` (from the Python itertools
     docs)
  -`sieve` (from the Python itertools docs)

* Other changes
  - Some documentation issues were fixed (thanks to nanouasyn)

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb [moved from meta/recipes-devtools/python/python3-more-itertools_8.14.0.bb with 86% similarity]

similarity index 86%
rename from meta/recipes-devtools/python/python3-more-itertools_8.14.0.bb
rename to meta/recipes-devtools/python/python3-more-itertools_9.0.0.bb
index c955f93d9b2a6415e6e686f5fdc7fa34d6534ce7..fce3aea8977708aeb51170f2999ee9f5e84cd423 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/erikrose/more-itertools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
 
-SRC_URI[sha256sum] = "c09443cd3d5438b8dafccd867a6bc1cb0894389e90cb53d227456b0b0bccb750"
+SRC_URI[sha256sum] = "5a6257e40878ef0520b1803990e3e22303a41b5714006c32a3fd8304b26ea1ab"
 
 inherit pypi python_flit_core ptest