]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core.git/commitdiff
vala: fix for gtk4 prior to 4.14
authorMarkus Volk <f_l_k@t-online.de>
Tue, 12 Mar 2024 05:22:07 +0000 (06:22 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2024 12:20:59 +0000 (12:20 +0000)
- add a backport patch to fix compatibility with older gtk4 versions

Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/vala/vala/0001-gtk4-Preserve-compatibility-with-4.14.patch [new file with mode: 0644]
meta/recipes-devtools/vala/vala_0.56.15.bb

diff --git a/meta/recipes-devtools/vala/vala/0001-gtk4-Preserve-compatibility-with-4.14.patch b/meta/recipes-devtools/vala/vala/0001-gtk4-Preserve-compatibility-with-4.14.patch
new file mode 100644 (file)
index 0000000..1614740
--- /dev/null
@@ -0,0 +1,39 @@
+From 17349020fb95454d06f827fd555b05248f10a370 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Thu, 7 Mar 2024 17:56:05 +0100
+Subject: [PATCH] gtk4: Preserve compatibility with < 4.14
+
+Don't prefer new accessor methods for Calendar.day/month/year
+
+Fixes https://gitlab.gnome.org/GNOME/vala/issues/1531
+
+Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/vala/-/commit/e0c4ea8c4a0bbf859b5341a7465b395892789d9e]
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+---
+ vapi/gtk4.vapi                 | 3 +++
+ vapi/metadata/Gtk-4.0.metadata | 5 +++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/vapi/gtk4.vapi b/vapi/gtk4.vapi
+index 49f8b2078..51ecea27d 100644
+--- a/vapi/gtk4.vapi
++++ b/vapi/gtk4.vapi
+@@ -7350,11 +7350,14 @@ namespace Gtk {
+               [Version (since = "4.14")]
+               public void set_year (int year);
+               public void unmark_day (uint day);
++              [NoAccessorMethod]
+               public int day { get; set; }
++              [NoAccessorMethod]
+               public int month { get; set; }
+               public bool show_day_names { get; set; }
+               public bool show_heading { get; set; }
+               public bool show_week_numbers { get; set; }
++              [NoAccessorMethod]
+               public int year { get; set; }
+               public signal void day_selected ();
+               public signal void next_month ();
+-- 
+2.44.0
+
index a8fdd0a97ad6851462f6e9a1d0e977c1e95d17e2..915ddd8e4d6cc1577b547122b027cb950381f6e7 100644 (file)
@@ -18,7 +18,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
 
 SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
 
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz"
+SRC_URI = " \
+       http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz \
+       file://0001-gtk4-Preserve-compatibility-with-4.14.patch \
+"
 SRC_URI[sha256sum] = "535b6452ed310fd5fb5c7dd6794b6213dac3b48e645e5bff3173741ec2cb3f2b"
 
 inherit autotools pkgconfig upstream-version-is-even