Update libvirt to 2.1