]> git.ipfire.org Git - ipfire-3.x.git/blobdiff - pkgs/pyserial/pyserial.nm
Change file layout of the makefiles.
[ipfire-3.x.git] / pkgs / pyserial / pyserial.nm
index a6cd3dcf0245ab9c6ab3d71170089aa59f1a9511..ba33766e819750fafeb1c1140e7e494c1fccf8da 100644 (file)
@@ -1,50 +1,36 @@
 ###############################################################################
-#                                                                             #
-# IPFire.org - A linux based firewall                                         #
-# Copyright (C) 2007, 2008 Michael Tremer & Christian Schmidt                 #
-#                                                                             #
-# This program is free software: you can redistribute it and/or modify        #
-# it under the terms of the GNU General Public License as published by        #
-# the Free Software Foundation, either version 3 of the License, or           #
-# (at your option) any later version.                                         #
-#                                                                             #
-# This program is distributed in the hope that it will be useful,             #
-# but WITHOUT ANY WARRANTY; without even the implied warranty of              #
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the               #
-# GNU General Public License for more details.                                #
-#                                                                             #
-# You should have received a copy of the GNU General Public License           #
-# along with this program.  If not, see <http://www.gnu.org/licenses/>.       #
-#                                                                             #
+# IPFire.org    - An Open Source Firewall Solution                            #
+# Copyright (C) - IPFire Development Team <info@ipfire.org>                   #
 ###############################################################################
 
-###############################################################################
-# Definitions
-###############################################################################
-
-include $(PKGROOT)/Include
+name       = pyserial
+version    = 2.5
+release    = 1
+arch       = noarch
 
-PKG_NAME       = pyserial
-PKG_VER        = 2.5
-PKG_REL        = 1
-PKG_ARCH       = noarch
+groups     = System/Libraries
+url        = http://pyserial.sourceforge.net/
+license    = Python
+summary    = Python Serial Port Extension.
 
-PKG_MAINTAINER =
-PKG_GROUPS     = System/Libraries
-PKG_URL        = http://pyserial.sourceforge.net/
-PKG_LICENSE    = Python
-PKG_SUMMARY    = Python Serial Port Extension.
+description
+       Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython.
+end
 
-PKG_BUILD_DEPS+= python-devel
+source_dl  =
 
-define PKG_DESCRIPTION
-       Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython.
-endef
+build
+       requires
+               python-devel
+       end
 
-PKG_TARBALL    = $(THISAPP).tar.gz
+       build = # Nothing to do
 
-STAGE_BUILD = # Nothing to do
+       install
+               python setup.py install --root=%{BUILDROOT}
+       end
+end
 
-define STAGE_INSTALL   
-       cd $(DIR_APP) && python setup.py install --root=$(BUILDROOT)
-endef
+packages
+       package %{name}
+end