Fix argument parsing of '--version'