Imported xen patches.
[people/pmueller/ipfire-2.x.git] / src / patches / 60049_xen-kconfig-compat-3.2.0.patch1
1 From: jbeulich@novell.com
2 Subject: add 3.2.0-compatibility configure option
3 Patch-mainline: obsolete
4
5 Index: head-2008-10-24/drivers/xen/Kconfig
6 ===================================================================
7 --- head-2008-10-24.orig/drivers/xen/Kconfig 2008-10-24 10:46:02.000000000 +0200
8 +++ head-2008-10-24/drivers/xen/Kconfig 2008-10-24 10:52:17.000000000 +0200
9 @@ -267,6 +267,9 @@ choice
10 config XEN_COMPAT_030100_AND_LATER
11 bool "3.1.0 and later"
12
13 + config XEN_COMPAT_030200_AND_LATER
14 + bool "3.2.0 and later"
15 +
16 config XEN_COMPAT_LATEST_ONLY
17 bool "no compatibility code"
18
19 @@ -275,6 +278,7 @@ endchoice
20 config XEN_COMPAT
21 hex
22 default 0xffffff if XEN_COMPAT_LATEST_ONLY
23 + default 0x030200 if XEN_COMPAT_030200_AND_LATER
24 default 0x030100 if XEN_COMPAT_030100_AND_LATER
25 default 0x030004 if XEN_COMPAT_030004_AND_LATER
26 default 0x030002 if XEN_COMPAT_030002_AND_LATER