Add missing modules for intersil/prism (disabled) to core35.
authorArne Fitzenreiter <arne_f@ipfire.org>
Mon, 11 Jan 2010 22:48:05 +0000 (23:48 +0100)
committerArne Fitzenreiter <arne_f@ipfire.org>
Mon, 11 Jan 2010 22:48:05 +0000 (23:48 +0100)
config/rootfiles/common/compat-wireless
config/rootfiles/core/35/filelists/files
config/rootfiles/core/35/update.sh
lfs/compat-wireless

index 955ed67..761f4f5 100644 (file)
@@ -1,2 +1,13 @@
 etc/system-release
 srv/web/ipfire/cgi-bin/country.cgi
+etc/modprobe.d/hostap
+lib/modules/2.6.27.42-ipfire/kernel/net/ieee80211/ieee80211.off
+lib/modules/2.6.27.42-ipfire/kernel/net/ieee80211/ieee80211_crypt.off
+lib/modules/2.6.27.42-ipfire/kernel/net/ieee80211/ieee80211_crypt_ccmp.off
+lib/modules/2.6.27.42-ipfire/kernel/net/ieee80211/ieee80211_crypt_tkip.off
+lib/modules/2.6.27.42-ipfire/kernel/net/ieee80211/ieee80211_crypt_wep.off
+lib/modules/2.6.27.42-ipfire-xen/kernel/net/ieee80211/ieee80211.off
+lib/modules/2.6.27.42-ipfire-xen/kernel/net/ieee80211/ieee80211_crypt.off
+lib/modules/2.6.27.42-ipfire-xen/kernel/net/ieee80211/ieee80211_crypt_ccmp.off
+lib/modules/2.6.27.42-ipfire-xen/kernel/net/ieee80211/ieee80211_crypt_tkip.off
+lib/modules/2.6.27.42-ipfire-xen/kernel/net/ieee80211/ieee80211_crypt_wep.off
index 377e2a1..6eaf629 100644 (file)
@@ -37,8 +37,9 @@ extract_files
 perl -e "require '/var/ipfire/lang.pl'; &Lang::BuildCacheLang"
 
 #
-#Run depmod -a to rebuld module informations
-depmod -a
+#Run depmod to rebuld module informations
+depmod 2.6.27.42-ipfire
+depmod 2.6.27.42-ipfire-xen
 #Finish
 #Don't report the exitcode last command
 exit 0
index 2c8d137..1cdff0e 100644 (file)
@@ -86,9 +86,23 @@ $(TARGET) : $(patsubst %,$(DIR_DL)/%,$(objects))
        # Set Regulatory Domain to "EU" (use Channel 1-14 max. 20db)
        echo options cfg80211 ieee80211_regdom=EU > /etc/modprobe.d/cfg80211
 
-       # Remove ieee80211 modules. Because the conflicts with compat-wireless
-       -rm -rf /lib/modules/$(KVER)-$(VERSUFIX)/kernel/net/ieee80211
+       # Rename ieee80211 modules Because the conflicts with compat-wireless
+       -cd /lib/modules/$(KVER)-$(VERSUFIX)/kernel/net/ieee80211 && rename .ko .off *
+
+       echo # If you want to use hostap (prism drivers) > /etc/modprobe.d/hostap
+       echo # you must rename the ieee80211 modules. Run: >> /etc/modprobe.d/hostap
+       echo # cd /lib/modules/$(uname -r)/kernel/net/ieee80211 && rename .off .ko >> /etc/modprobe.d/hostap
+       echo # depmod -a >> /etc/modprobe.d/hostap
+       echo >> /etc/modprobe.d/hostap
+       echo # additional you need to blacklist the orinoco modules >> /etc/modprobe.d/hostap
+       echo # by uncommenting following lines >> /etc/modprobe.d/hostap
+       echo >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco_cs >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco_plx >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco_pci >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco_tmd >> /etc/modprobe.d/hostap
+       echo #blacklist orinoco_nortel >> /etc/modprobe.d/hostap
 
        -rm -rf $(DIR_APP)
        @$(POSTBUILD)
-