Update ppp to 2.4.5.