Improve Makefile.
[people/stevee/guardian.git] / README
1 guardian
2
3 A perl written Intrusion Prevention System.
4
5 WEB HOME:
6         http://git.ipfire.org/?p=people/stevee/guardian.git;a=summary
7
8 BUGTRACKER:
9         Please report any found bugs to the IPFire development mailing list
10         <development@lists.ipfire.org> until a bugtracker will be available.
11
12 LICENSE:
13         The authors licensed their work as free software under the terms of
14         the
15
16                 GNU GENERAL PUBLIC LICENSE v3.0+
17
18         Any content besides source code (images, etc.) is licensed under the
19         terms of the
20
21                 Creative Commons Attribution ShareAlike 3.0 Unported
22
23         license.
24
25 INSTALLATION:
26         REQUIREMENTS:
27                 guardian is written in pure Perl and requires the following third-party
28                 modules to work:
29                         * Linux-Inotify2 (http://search.cpan.org/~mlehmann/Linux-Inotify2-1.22/)
30                         * Net-IP (http://search.cpan.org/~manu/Net-IP-1.26/)
31                 The minimum version of Perl that has been tested is Perl 5.12.
32
33                 Building the program requires:
34                         * GNU make
35                         * sed
36
37         INSTRUCTIONS:
38                 To build and install run:
39                         make
40                         make install