]> git.ipfire.org Git - thirdparty/e2fsprogs.git/blame - e2fsprogs.spec
libss: fix function delcaration in the test_ss regression test
[thirdparty/e2fsprogs.git] / e2fsprogs.spec
CommitLineData
d606c308
TT
1%define _root_sbindir /sbin
2%define _root_libdir /%{_lib}
36569f87 3%define _root_localedir /usr/share/locale
927566a3 4%define _root_etcdir /etc
d606c308 5
e2193cf4 6Summary: Utilities for managing ext2/ext3/ext4 filesystems
24757fa0 7Name: e2fsprogs
25ad8a43 8Version: 1.47.0
24757fa0 9Release: 0
f6c9b0e2 10License: GPLv2
8a31ffef 11Group: System Environment/Base
d606c308
TT
12Source: ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
13Url: http://e2fsprogs.sourceforge.net/
f9e67064 14Prereq: /sbin/ldconfig
d606c308 15BuildRoot: %{_tmppath}/%{name}-root
24757fa0
TT
16
17%description
8a31ffef 18The e2fsprogs package contains a number of utilities for creating,
e2193cf4
TT
19checking, modifying, and correcting any inconsistencies in ext2, ext3,
20and ext4 filesystems. E2fsprogs contains e2fsck (used to repair
21filesystem inconsistencies after an unclean shutdown), mke2fs (used to
22initialize a partition to contain an empty ext2 filesystem), debugfs
23(used to examine the internal structure of a filesystem, to manually
24repair a corrupted filesystem or to create test cases for e2fsck),
25tune2fs (used to modify filesystem parameters), resize2fs to grow and
26shrink unmounted ext2 filesystems, and most of the other core ext2fs
27filesystem utilities.
8a31ffef 28
e2193cf4
TT
29You should install the e2fsprogs package if you are using any ext2,
30ext3, or ext4 filesystems (if you're not sure, you probably should
31install this package). You may also need to install it (even if you
32don't use ext2/ext3/ext4) for the libuuid and libblkid libraries and
33fsck tool that are included here.
24757fa0
TT
34
35%package devel
8a31ffef 36Summary: Ext2 filesystem-specific static libraries and headers.
24757fa0 37Group: Development/Libraries
d606c308
TT
38Requires: e2fsprogs = %{version}
39Prereq: /sbin/install-info
24757fa0 40
f9e67064 41%description devel
8a31ffef 42E2fsprogs-devel contains the libraries and header files needed to
e2193cf4 43develop ext2, ext3, or ext4 filesystem-specific programs.
8a31ffef 44
e2193cf4
TT
45You should install e2fsprogs-devel if you want to develop
46ext2. ext3. or ext4 filesystem-specific programs. If you install
47e2fsprogs-devel, you'll also want to install e2fsprogs.
24757fa0 48
f8897f4e
ES
49%package -n uuidd
50Summary: helper daemon to guarantee uniqueness of time-based UUIDs
51Group: System Environment/Daemons
52License: GPLv2
53Requires: e2fsprogs = %{version}
54Requires(pre): shadow-utils
55
56%description -n uuidd
57The uuidd package contains a userspace daemon (uuidd) which guarantees
58uniqueness of time-based UUID generation even at very high rates on
59SMP systems.
60
24757fa0
TT
61%prep
62%setup
63
d606c308 64%build
28b74daa
AD
65%configure --enable-elf-shlibs --enable-nls \
66 %{?extra_config_flags:%extra_config_flags}
cf1b23ef 67make
c5ca71df 68make check
24757fa0
TT
69
70%install
f9e67064 71rm -rf $RPM_BUILD_ROOT
24757fa0 72export PATH=/sbin:$PATH
d606c308
TT
73make install install-libs DESTDIR="$RPM_BUILD_ROOT" \
74 root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
cf1b23ef 75/sbin/ldconfig -n ${RPM_BUILD_ROOT}%{_libdir}
f8897f4e
ES
76
77# Add a dir that uuidd needs that the Makefiles don't create
78install -d $RPM_BUILD_ROOT/var/lib/libuuid
79
cf1b23ef 80%find_lang %{name}
24757fa0 81
24757fa0
TT
82%clean
83rm -rf $RPM_BUILD_ROOT
84
d606c308 85%post -p /sbin/ldconfig
24757fa0 86
f9e67064
TT
87%postun -p /sbin/ldconfig
88
89%post devel
d606c308 90if [ -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
cf1b23ef 91 /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
f9e67064 92fi
cf1b23ef 93exit 0
f9e67064
TT
94
95%postun devel
d606c308 96if [ $1 = 0 -a -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
f5955dda 97 /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
f9e67064 98fi
cf1b23ef 99exit 0
24757fa0 100
f8897f4e
ES
101%pre -n uuidd
102getent group uuidd >/dev/null || groupadd -r uuidd
103getent passwd uuidd >/dev/null || \
104useradd -r -g uuidd -d /var/lib/libuuid -s /sbin/nologin \
105 -c "UUID generator helper daemon" uuidd
106exit 0
107
cf1b23ef 108%files -f %{name}.lang
f9e67064
TT
109%defattr(-,root,root)
110%doc README RELEASE-NOTES
111
d606c308 112%{_root_sbindir}/badblocks
cf1b23ef 113%{_root_sbindir}/blkid
d606c308
TT
114%{_root_sbindir}/debugfs
115%{_root_sbindir}/dumpe2fs
116%{_root_sbindir}/e2fsck
117%{_root_sbindir}/e2image
118%{_root_sbindir}/e2label
32b8802a 119%{_root_sbindir}/e2mmpstatus
9ea7b792 120%{_root_sbindir}/e2undo
d606c308
TT
121%{_root_sbindir}/findfs
122%{_root_sbindir}/fsck
123%{_root_sbindir}/fsck.ext2
124%{_root_sbindir}/fsck.ext3
eda08d45
TT
125%{_root_sbindir}/fsck.ext4
126%{_root_sbindir}/fsck.ext4dev
f9ddad59 127%{_root_sbindir}/logsave
d606c308 128%{_root_sbindir}/mke2fs
927566a3 129%{_root_etcdir}/mke2fs.conf
d606c308
TT
130%{_root_sbindir}/mkfs.ext2
131%{_root_sbindir}/mkfs.ext3
eda08d45
TT
132%{_root_sbindir}/mkfs.ext4
133%{_root_sbindir}/mkfs.ext4dev
d606c308
TT
134%{_root_sbindir}/resize2fs
135%{_root_sbindir}/tune2fs
477b2353 136%{_sbindir}/filefrag
cf1b23ef 137%{_sbindir}/mklost+found
0b2681f4 138%{_sbindir}/e2freefrag
d606c308 139
cf1b23ef 140%{_root_libdir}/libblkid.so.*
d606c308
TT
141%{_root_libdir}/libcom_err.so.*
142%{_root_libdir}/libe2p.so.*
143%{_root_libdir}/libext2fs.so.*
144%{_root_libdir}/libss.so.*
d606c308
TT
145%{_root_libdir}/libuuid.so.*
146
6ea8d0f7
TT
147%{_libdir}/e2initrd_helper
148
d606c308
TT
149%{_bindir}/chattr
150%{_bindir}/lsattr
151%{_bindir}/uuidgen
16c1ce89
TT
152%{_mandir}/man1/chattr.1*
153%{_mandir}/man1/lsattr.1*
154%{_mandir}/man1/uuidgen.1*
155
927566a3
AD
156%{_mandir}/man5/e2fsck.conf.5*
157%{_mandir}/man5/mke2fs.conf.5*
158
16c1ce89 159%{_mandir}/man8/badblocks.8*
d606c308 160%{_mandir}/man8/blkid.8*
16c1ce89
TT
161%{_mandir}/man8/debugfs.8*
162%{_mandir}/man8/dumpe2fs.8*
163%{_mandir}/man8/e2fsck.8*
d606c308
TT
164%{_mandir}/man8/findfs.8*
165%{_mandir}/man8/fsck.ext2.8*
166%{_mandir}/man8/fsck.ext3.8*
eda08d45
TT
167%{_mandir}/man8/fsck.ext4.8*
168%{_mandir}/man8/fsck.ext4dev.8*
d5d9215f 169%{_mandir}/man8/e2image.8*
d606c308 170%{_mandir}/man8/e2label.8*
32b8802a 171%{_mandir}/man8/e2mmpstatus.8*
9ea7b792 172%{_mandir}/man8/e2undo.8*
16c1ce89 173%{_mandir}/man8/fsck.8*
f9ddad59 174%{_mandir}/man8/logsave.8*
16c1ce89 175%{_mandir}/man8/mke2fs.8*
d606c308
TT
176%{_mandir}/man8/mkfs.ext2.8*
177%{_mandir}/man8/mkfs.ext3.8*
eda08d45
TT
178%{_mandir}/man8/mkfs.ext4.8*
179%{_mandir}/man8/mkfs.ext4dev.8*
16c1ce89
TT
180%{_mandir}/man8/mklost+found.8*
181%{_mandir}/man8/resize2fs.8*
182%{_mandir}/man8/tune2fs.8*
477b2353 183%{_mandir}/man8/filefrag.8*
0b2681f4 184%{_mandir}/man8/e2freefrag.8*
24757fa0
TT
185
186%files devel
f9e67064 187%defattr(-,root,root)
f5955dda 188%{_infodir}/libext2fs.info*
d606c308
TT
189%{_bindir}/compile_et
190%{_bindir}/mk_cmds
191
cf1b23ef
TT
192%{_libdir}/libblkid.a
193%{_libdir}/libblkid.so
d606c308
TT
194%{_libdir}/libcom_err.a
195%{_libdir}/libcom_err.so
196%{_libdir}/libe2p.a
197%{_libdir}/libe2p.so
198%{_libdir}/libext2fs.a
199%{_libdir}/libext2fs.so
200%{_libdir}/libss.a
201%{_libdir}/libss.so
d606c308
TT
202%{_libdir}/libuuid.a
203%{_libdir}/libuuid.so
204
e6441865
TT
205%{_libdir}/pkgconfig/blkid.pc
206%{_libdir}/pkgconfig/com_err.pc
207%{_libdir}/pkgconfig/e2p.pc
208%{_libdir}/pkgconfig/ext2fs.pc
209%{_libdir}/pkgconfig/ss.pc
210%{_libdir}/pkgconfig/uuid.pc
211
d606c308
TT
212%{_datadir}/et
213%{_datadir}/ss
214%{_includedir}/blkid
cf1b23ef 215%{_includedir}/e2p
d606c308 216%{_includedir}/et
cf5301d7 217%{_includedir}/com_err.h
d606c308
TT
218%{_includedir}/ext2fs
219%{_includedir}/ss
220%{_includedir}/uuid
16c1ce89 221%{_mandir}/man1/compile_et.1*
cf1b23ef 222%{_mandir}/man1/mk_cmds.1*
16c1ce89 223%{_mandir}/man3/com_err.3*
d606c308 224%{_mandir}/man3/libblkid.3*
6d493497 225%{_mandir}/man3/uuid.3*
cf1b23ef
TT
226%{_mandir}/man3/uuid_clear.3*
227%{_mandir}/man3/uuid_compare.3*
228%{_mandir}/man3/uuid_copy.3*
229%{_mandir}/man3/uuid_generate.3*
230%{_mandir}/man3/uuid_generate_random.3*
231%{_mandir}/man3/uuid_generate_time.3*
232%{_mandir}/man3/uuid_is_null.3*
233%{_mandir}/man3/uuid_parse.3*
234%{_mandir}/man3/uuid_time.3*
235%{_mandir}/man3/uuid_unparse.3*
236
f8897f4e
ES
237%files -n uuidd
238%defattr(-,root,root)
239# if you want to run via init
240# /etc/init.d/uuidd
241%{_mandir}/man8/uuidd.8*
242%attr(6755, uuidd, uuidd) %{_sbindir}/uuidd
243%dir %attr(2775, uuidd, uuidd) /var/lib/libuuid
244