]> git.ipfire.org Git - thirdparty/freeswitch.git/blame - freeswitch-config-rayo.spec
Merge pull request #2163 from signalwire/MEDIA_PARAMS
[thirdparty/freeswitch.git] / freeswitch-config-rayo.spec
CommitLineData
d9a8dd0b
CR
1######################################################################################################################
2#
3# freeswitch-config-rayo for FreeSWITCH Modular Media Switching Software Library / Soft-Switch Application
66486713 4# Copyright (C) 2013-2015, Grasshopper
d9a8dd0b
CR
5#
6# Version: MPL 1.1
7#
8# The contents of this file are subject to the Mozilla Public License Version
9# 1.1 (the "License"); you may not use this file except in compliance with
10# the License. You may obtain a copy of the License at
11# http://www.mozilla.org/MPL/
12#
13# Software distributed under the License is distributed on an "AS IS" basis,
14# WITHOUT WARRANTY OF ANY KIND, either express or implied. See the License
15# for the specific language governing rights and limitations under the
16# License.
17#
18# The Original Code is freeswitch-config-rayo for FreeSWITCH Modular Media Switching Software Library / Soft-Switch Application
19#
20# The Initial Developer of the Original Code is Grasshopper
21# Portions created by the Initial Developer are Copyright (C)
22# the Initial Developer. All Rights Reserved.
23#
24# Contributor(s):
25# Chris Rienzo <crienzo@grasshopper.com>
26#
27# freeswitch-rayo-config -- RPM packaging for Rayo Server configuration
28#
29######################################################################################################################
30
efd35f68
AV
31%define nonparsedversion 1.7.0
32%define version %(echo '%{nonparsedversion}' | sed 's/-//g')
66486713 33%define release 1
d9a8dd0b
CR
34
35%define fsname freeswitch
36
37%define PREFIX %{_prefix}
38%define EXECPREFIX %{_exec_prefix}
39%define BINDIR %{_bindir}
40%define SBINDIR %{_sbindir}
41%define LIBEXECDIR %{_libexecdir}/%fsname
42%define SYSCONFDIR %{_sysconfdir}/%fsname
43%define SHARESTATEDIR %{_sharedstatedir}/%fsname
44%define LOCALSTATEDIR %{_localstatedir}/lib/%fsname
45%define LIBDIR %{_libdir}
46%define INCLUDEDIR %{_includedir}
47%define _datarootdir %{_prefix}/share
48%define DATAROOTDIR %{_datarootdir}
49%define DATADIR %{_datadir}
50%define INFODIR %{_infodir}
51%define LOCALEDIR %{_datarootdir}/locale
52%define MANDIR %{_mandir}
53%define DOCDIR %{_defaultdocdir}/%fsname
54%define HTMLDIR %{_defaultdocdir}/%fsname/html
55%define DVIDIR %{_defaultdocdir}/%fsname/dvi
56%define PDFDIR %{_defaultdocdir}/%fsname/pdf
57%define PSDIR %{_defaultdocdir}/%fsname/ps
58%define LOGFILEDIR /var/log/%fsname
59%define MODINSTDIR %{_libdir}/%fsname/mod
60%define RUNDIR %{_localstatedir}/run/%fsname
61%define DBDIR %{LOCALSTATEDIR}/db
62%define HTDOCSDIR %{_datarootdir}/%fsname/htdocs
63%define SOUNDSDIR %{_datarootdir}/%fsname/sounds
64%define GRAMMARDIR %{_datarootdir}/%fsname/grammar
65%define SCRIPTDIR %{_datarootdir}/%fsname/scripts
66%define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
67%define PKGCONFIGDIR %{_datarootdir}/%fsname/pkgconfig
68%define HOMEDIR %{LOCALSTATEDIR}
69
70Name: freeswitch-config-rayo
71Version: %{version}
72Release: %{release}%{?dist}
73License: MPL1.1
74Summary: Rayo configuration for the FreeSWITCH Open Source telephone platform.
75Group: System/Libraries
76Packager: Chris Rienzo
77URL: http://www.freeswitch.org/
efd35f68 78Source0: freeswitch-%{nonparsedversion}.tar.bz2
d94e3934 79Requires: freeswitch
d9a8dd0b
CR
80Requires: freeswitch-application-conference
81Requires: freeswitch-application-esf
82Requires: freeswitch-application-expr
83Requires: freeswitch-application-fsv
84Requires: freeswitch-application-http-cache
85Requires: freeswitch-asrtts-flite
86Requires: freeswitch-asrtts-pocketsphinx
d9a8dd0b
CR
87Requires: freeswitch-codec-h26x
88Requires: freeswitch-codec-ilbc
89Requires: freeswitch-codec-opus
d9a8dd0b
CR
90Requires: freeswitch-codec-vp8
91Requires: freeswitch-event-rayo
92Requires: freeswitch-format-local-stream
93Requires: freeswitch-format-mod-shout
94Requires: freeswitch-format-shell-stream
95Requires: freeswitch-format-ssml
96Requires: freeswitch-sounds-music-8000
d9a8dd0b
CR
97Requires: freeswitch-lang-en
98Requires: freeswitch-sounds-en-us-callie-8000
d9a8dd0b
CR
99BuildRequires: bash
100BuildArch: noarch
101BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
102
103%description
104FreeSWITCH rayo server implementation.
105
106%prep
efd35f68 107%setup -b0 -q -n freeswitch-%{nonparsedversion}
d9a8dd0b
CR
108
109%build
110
111%install
112%{__rm} -rf %{buildroot}
113%{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}
114%{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/autoload_configs
115%{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/dialplan
116%{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/sip_profiles
117%{__install} -d -m 0750 %{buildroot}/%{SYSCONFDIR}/directory
118%{__cp} -prv ./conf/rayo/*.{xml,types,pem} %{buildroot}/%{SYSCONFDIR}/
119%{__cp} -prv ./conf/rayo/{autoload_configs,dialplan} %{buildroot}/%{SYSCONFDIR}/
120%{__cp} -prv ./conf/rayo/sip_profiles/external.xml %{buildroot}/%{SYSCONFDIR}/sip_profiles
121%{__cp} -prv ./conf/rayo/sip_profiles/external %{buildroot}/%{SYSCONFDIR}/sip_profiles
122%{__cp} -prv ./conf/rayo/directory %{buildroot}/%{SYSCONFDIR}/
123
124%postun
125
126%clean
127%{__rm} -rf %{buildroot}
128
129%files
130%defattr(-,freeswitch,daemon)
131%dir %attr(0750, freeswitch, daemon) %{SYSCONFDIR}
132%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/cacert.pem
133%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/*.xml
134%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/mime.types
135%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/acl.conf.xml
136%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/cdr_csv.conf.xml
137%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/conference.conf.xml
138%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/console.conf.xml
139%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/event_socket.conf.xml
140%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/http_cache.conf.xml
141%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/local_stream.conf.xml
142%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/logfile.conf.xml
143%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/modules.conf.xml
144%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/pocketsphinx.conf.xml
145%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/post_load_modules.conf.xml
146%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/presence_map.conf.xml
147%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/rayo.conf.xml
148%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/shout.conf.xml
149%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/sofia.conf.xml
150%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/spandsp.conf.xml
151%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/ssml.conf.xml
152%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/switch.conf.xml
153%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/autoload_configs/timezones.conf.xml
154%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/dialplan/public.xml
155%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/directory/default.xml
156%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/directory/default/*.xml
157%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/sip_profiles/*.xml
158%config(noreplace) %attr(0640, freeswitch, daemon) %{SYSCONFDIR}/sip_profiles/external/*.xml
159
160### END OF config-rayo
161
162######################################################################################################################
163#
164# Changelog
165#
166######################################################################################################################
167%changelog
886b2d39
AV
168* Tue Apr 23 2019 - Andrey Volk
169- Fix build for Stack 20.x
d94e3934
CR
170* Tue Jun 10 2014 crienzo@grasshopper.com
171- Remove dependency to high resolution music and sounds files
172- Remove dependency to specific FreeSWITCH package version
d9a8dd0b
CR
173* Mon Jun 03 2013 - crienzo@grasshopper.com
174- Added users and internal profile for softphone testing
175* Wed May 08 2013 - crienzo@grasshopper.com
176- Initial revision
177