]> git.ipfire.org Git - thirdparty/freeswitch.git/blame - freeswitch-sounds-pt-BR-karina.spec
Merge pull request #2449 from signalwire/fix_scan_build_mod_amrwb
[thirdparty/freeswitch.git] / freeswitch-sounds-pt-BR-karina.spec
CommitLineData
b420a304
KR
1##############################################################################
2# Copyright and license
3##############################################################################
4#
2fb5a393 5# Spec file for package freeswitch-sounds-pt-BR-karina (version 1.0.51-1)
b420a304
KR
6#
7# Based on parts by Copyright (c) 2009 Patrick Laimbock
8# Copyright (c) 2014 FreeSWITCH.org
9# This file and all modifications and additions to the pristine
10# package are under the same license as the package itself.
11#
12
13##############################################################################
14# Set variables
15##############################################################################
16
2fb5a393 17%define version 1.0.51
b420a304
KR
18%define release 1
19
20%define fsname freeswitch
21# you could add a version number to be more strict
22
23%define PREFIX %{_prefix}
24%define EXECPREFIX %{_exec_prefix}
25%define BINDIR %{_bindir}
26%define SBINDIR %{_sbindir}
27%define LIBEXECDIR %{_libexecdir}/%{fsname}
28%define SYSCONFDIR %{_sysconfdir}/%{fsname}
29%define SHARESTATEDIR %{_sharedstatedir}/%{fsname}
30%define LOCALSTATEDIR %{_localstatedir}/lib/%{fsname}
31%define LIBDIR %{_libdir}
32%define INCLUDEDIR %{_includedir}
33%define _datarootdir %{_prefix}/share
34%define DATAROOTDIR %{_datarootdir}
35%define DATADIR %{_datadir}
36%define INFODIR %{_infodir}
37%define LOCALEDIR %{_datarootdir}/locale
38%define MANDIR %{_mandir}
39%define DOCDIR %{_defaultdocdir}/%{fsname}
40%define HTMLDIR %{_defaultdocdir}/%{fsname}/html
41%define DVIDIR %{_defaultdocdir}/%{fsname}/dvi
42%define PDFDIR %{_defaultdocdir}/%{fsname}/pdf
43%define PSDIR %{_defaultdocdir}/%{fsname}/ps
44%define LOGFILEDIR /var/log/%{fsname}
45%define MODINSTDIR %{_libdir}/%{fsname}/mod
46%define RUNDIR %{_localstatedir}/run/%{fsname}
47%define DBDIR %{LOCALSTATEDIR}/db
48%define HTDOCSDIR %{_datarootdir}/%{fsname}/htdocs
49%define SOUNDSDIR %{_datarootdir}/%{fsname}/sounds
50%define GRAMMARDIR %{_datarootdir}/%{fsname}/grammar
51%define SCRIPTDIR %{_datarootdir}/%{fsname}/scripts
52%define RECORDINGSDIR %{LOCALSTATEDIR}/recordings
53%define PKGCONFIGDIR %{_datarootdir}/%{fsname}/pkgconfig
54%define HOMEDIR %{LOCALSTATEDIR}
55
56
57
58
59
60##############################################################################
61# General
62##############################################################################
63
64Summary: FreeSWITCH pt-BR Karina prompts
65Name: freeswitch-sounds-pt-BR-karina
66Version: %{version}
67Release: %{release}%{?dist}
68License: MPL
69Group: Applications/Communications
70Packager: Ken Rice <krice@freeswitch.org>
71URL: http://www.freeswitch.org
861c4e9c
KR
72Source0:http://files.freeswitch.org/releases/sounds/%{name}-48000-%{version}.tar.gz
73Source1:http://files.freeswitch.org/releases/sounds/%{name}-32000-%{version}.tar.gz
74Source2:http://files.freeswitch.org/releases/sounds/%{name}-16000-%{version}.tar.gz
75Source3:http://files.freeswitch.org/releases/sounds/%{name}-8000-%{version}.tar.gz
b420a304
KR
76BuildArch: noarch
77BuildRequires: sox
78Requires: freeswitch
79Requires: freeswitch-sounds-pt-BR-karina-48000
80BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
81
82%description
83FreeSWITCH 48kHz fr BR Karina prompts plus, during the installation,
84it will also install locally generated 8KHz, 16KHz and 32KHz prompts
85
86%package -n freeswitch-sounds-pt-BR-karina-8000
87Summary: FreeSWITCH 8kHz fr BR Karina prompts
88Group: Applications/Communications
89BuildArch: noarch
90Requires: %{fsname}
91
92%description -n freeswitch-sounds-pt-BR-karina-8000
93FreeSWITCH 8kHz fr BR Karina prompts
94
95%package -n freeswitch-sounds-pt-BR-karina-16000
96Summary: FreeSWITCH 16kHz fr BR Karina prompts
97Group: Applications/Communications
98BuildArch: noarch
99Requires: %{fsname}
100
101%description -n freeswitch-sounds-pt-BR-karina-16000
102FreeSWITCH 16kHz fr BR Karina prompts
103
104%package -n freeswitch-sounds-pt-BR-karina-32000
105Summary: FreeSWITCH 32kHz fr BR Karina prompts
106Group: Applications/Communications
107BuildArch: noarch
108Requires: %{fsname}
109
110%description -n freeswitch-sounds-pt-BR-karina-32000
111FreeSWITCH 32kHz fr BR Karina prompts
112
113%package -n freeswitch-sounds-pt-BR-karina-48000
114Summary: FreeSWITCH 48kHz fr BR Karina prompts
115Group: Applications/Communications
116BuildArch: noarch
117Requires: %{fsname}
118
119%description -n freeswitch-sounds-pt-BR-karina-48000
120FreeSWITCH 48kHz fr BR Karina prompts
121
122%package -n freeswitch-sounds-pt-BR-karina-all
123Summary: FreeSWITCH fr BR Karina prompts
124Group: Applications/Communications
125BuildArch: noarch
126Requires: %{fsname}
127Requires: freeswitch-sounds-pt-BR-karina-8000 = %{version}
128Requires: freeswitch-sounds-pt-BR-karina-16000 = %{version}
129Requires: freeswitch-sounds-pt-BR-karina-32000 = %{version}
130Requires: freeswitch-sounds-pt-BR-karina-48000 = %{version}
131
132%description -n freeswitch-sounds-pt-BR-karina-all
133FreeSWITCH Elena prompts package that pulls in the 8KHz, 16KHz, 32KHz and 48KHz RPMs
134
135##############################################################################
136# Prep
137##############################################################################
138
139%prep
140%setup -n pt
141%setup -T -D -b 0 -n pt
142%setup -T -D -b 1 -n pt
143%setup -T -D -b 2 -n pt
144%setup -T -D -b 3 -n pt
145
146##############################################################################
147# Build
148##############################################################################
149
150%build
151# nothing to do here
152
153##############################################################################
154# Install
155##############################################################################
156
157%install
158[ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
159
160# create the sounds directories
161%{__install} -d -m 0750 %{buildroot}%{SOUNDSDIR}/pt/BR/karina
162
163pushd BR/karina
164# first install the 48KHz sounds
165%{__cp} -prv ./* %{buildroot}%{SOUNDSDIR}/pt/BR/karina
166popd
167
168##############################################################################
169# Clean
170##############################################################################
171
172%clean
173[ "%{buildroot}" != '/' ] && rm -rf %{buildroot}
174
175##############################################################################
176# Post
177##############################################################################
178
179%post
180
181##############################################################################
182# Postun
183##############################################################################
184
185%postun
186
187##############################################################################
188# Files
189##############################################################################
190
191%files
192%defattr(-,root,root)
193
194%files -n freeswitch-sounds-pt-BR-karina-8000
195%defattr(-,root,root,-)
196%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ascii/8000
197%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/base256/8000
198%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/conference/8000
199%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/currency/8000
200%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/digits/8000
201%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/directory/8000
202%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ivr/8000
203%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/misc/8000
204%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/8000
205%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/time/8000
206%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/voicemail/8000
207%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/zrtp/8000
208#%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/users/8000
209%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ascii/8000/*.wav
210%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/base256/8000/*.wav
211%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/conference/8000/*.wav
212%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/currency/8000/*.wav
213%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/digits/8000/*.wav
214%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/directory/8000/*.wav
215%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ivr/8000/*.wav
216%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/misc/8000/*.wav
217%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/8000/*.wav
218%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/time/8000/*.wav
219%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/voicemail/8000/*.wav
220%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/zrtp/8000/*.wav
221#%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/users/8000/*.wav
222
223%files -n freeswitch-sounds-pt-BR-karina-16000
224%defattr(-,root,root,-)
225%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ascii/16000
226%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/base256/16000
227%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/conference/16000
228%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/currency/16000
229%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/digits/16000
230%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/directory/16000
231%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ivr/16000
232%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/misc/16000
233%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/16000
234%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/time/16000
235%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/voicemail/16000
236%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/zrtp/16000
237#%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/users/16000
238%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ascii/16000/*.wav
239%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/base256/16000/*.wav
240%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/conference/16000/*.wav
241%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/currency/16000/*.wav
242%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/digits/16000/*.wav
243%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/directory/16000/*.wav
244%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ivr/16000/*.wav
245%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/misc/16000/*.wav
246%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/16000/*.wav
247%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/time/16000/*.wav
248%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/voicemail/16000/*.wav
249%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/zrtp/16000/*.wav
250#%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/users/16000/*.wav
251
252%files -n freeswitch-sounds-pt-BR-karina-32000
253%defattr(-,root,root,-)
254%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ascii/32000
255%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/base256/32000
256%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/conference/32000
257%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/currency/32000
258%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/digits/32000
259%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/directory/32000
260%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ivr/32000
261%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/misc/32000
262%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/32000
263%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/time/32000
264%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/voicemail/32000
265%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/zrtp/32000
266#%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/users/32000
267%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ascii/32000/*.wav
268%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/base256/32000/*.wav
269%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/conference/32000/*.wav
270%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/currency/32000/*.wav
271%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/digits/32000/*.wav
272%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/directory/32000/*.wav
273%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ivr/32000/*.wav
274%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/misc/32000/*.wav
275%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/32000/*.wav
276%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/time/32000/*.wav
277%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/voicemail/32000/*.wav
278%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/zrtp/32000/*.wav
279#%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/users/32000/*.wav
280
281%files -n freeswitch-sounds-pt-BR-karina-48000
282%defattr(-,root,root,-)
283%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ascii/48000
284%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/base256/48000
285%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/conference/48000
286%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/currency/48000
287%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/digits/48000
288%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/directory/48000
289%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/ivr/48000
290%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/misc/48000
291%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/48000
292%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/time/48000
293%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/voicemail/48000
294%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/zrtp/48000
295#%attr(0750,freeswitch,daemon) %dir %{SOUNDSDIR}/pt/BR/karina/users/48000
296%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ascii/48000/*.wav
297%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/base256/48000/*.wav
298%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/conference/48000/*.wav
299%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/currency/48000/*.wav
300%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/digits/48000/*.wav
301%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/directory/48000/*.wav
302%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/ivr/48000/*.wav
303%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/misc/48000/*.wav
304%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/phonetic-ascii/48000/*.wav
305%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/time/48000/*.wav
306%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/voicemail/48000/*.wav
307%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/zrtp/48000/*.wav
308#%attr(0640,freeswitch,daemon) %{SOUNDSDIR}/pt/BR/karina/users/48000/*.wav
309
310%files -n freeswitch-sounds-pt-BR-karina-all
311
312##############################################################################
313# Changelog
314##############################################################################
315
316%changelog
2fb5a393
AV
317* Fri Apr 19 2019 Andrey Volk <andrey@signalwire.com> - 1.0.51-1
318- bump up version
b420a304
KR
319* Fri Sep 12 2014 Ken Rice <krice@freeswitch.org> - 1.0.50-1
320- created out of the spec file for june