]> git.ipfire.org Git - thirdparty/mdadm.git/blob - mdadm.spec
imsm: fix activate_spare off-by-one
[thirdparty/mdadm.git] / mdadm.spec
1 Summary: mdadm is used for controlling Linux md devices (aka RAID arrays)
2 Name: mdadm
3 Version: 3.0
4 Release: 1
5 Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tgz
6 URL: http://neil.brown.name/blog/mdadm
7 License: GPL
8 Group: Utilities/System
9 BuildRoot: %{_tmppath}/%{name}-root
10 Obsoletes: mdctl
11
12 %description
13 mdadm is a program that can be used to create, manage, and monitor
14 Linux MD (Software RAID) devices.
15 As such is provides similar functionality to the raidtools packages.
16 The particular differences to raidtools is that mdadm is a single
17 program, and it can perform (almost) all functions without a
18 configuration file (that a config file can be used to help with
19 some common tasks).
20
21 %prep
22 %setup -q
23 # we want to install in /sbin, not /usr/sbin...
24 %define _exec_prefix %{nil}
25
26 %build
27 # This is a debatable issue. The author of this RPM spec file feels that
28 # people who install RPMs (especially given that the default RPM options
29 # will strip the binary) are not going to be running gdb against the
30 # program.
31 make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}"
32
33 %install
34 make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=%{_sbindir} install
35 install -D -m644 mdadm.conf-example $RPM_BUILD_ROOT/%{_sysconfdir}/mdadm.conf
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(-,root,root)
42 %doc TODO ChangeLog mdadm.conf-example COPYING
43 %{_sbindir}/mdadm
44 %config(noreplace,missingok)/%{_sysconfdir}/mdadm.conf
45 %{_mandir}/man*/md*
46
47 %changelog
48 * Fri May 10 2002 <neilb@cse.unsw.edu.au>
49 - update to 1.0.0
50 - Set CXFLAGS instead of CFLAGS
51
52 * Sat Apr 6 2002 <neilb@cse.unsw.edu.au>
53 - change install to use "make install"
54
55 * Fri Mar 15 2002 <gleblanc@localhost.localdomain>
56 - beautification
57 - made mdadm.conf non-replaceable config
58 - renamed Copyright to License in the header
59 - added missing license file
60 - used macros for file paths
61
62 * Fri Mar 15 2002 Luca Berra <bluca@comedia.it>
63 - Added Obsoletes: mdctl
64 - missingok for configfile
65
66 * Wed Mar 12 2002 NeilBrown <neilb@cse.unsw.edu.au>
67 - Add md.4 and mdadm.conf.5 man pages
68
69 * Fri Mar 08 2002 Chris Siebenmann <cks@cquest.utoronto.ca>
70 - builds properly as non-root.
71
72 * Fri Mar 08 2002 Derek Vadala <derek@cynicism.com>
73 - updated for 0.7, fixed /usr/share/doc and added manpage
74
75 * Tue Aug 07 2001 Danilo Godec <danci@agenda.si>
76 - initial RPM build