]> git.ipfire.org Git - thirdparty/mdadm.git/blob - mdadm.spec
tests: add test that DDF marks missing devices as failed on assembly.
[thirdparty/mdadm.git] / mdadm.spec
1 Summary: mdadm is used for controlling Linux md devices (aka RAID arrays)
2 Name: mdadm
3 Version: 3.3
4 Release: 1
5 Source: http://www.kernel.org/pub/linux/utils/raid/mdadm/mdadm-%{version}.tar.gz
6 URL: http://neil.brown.name/blog/mdadm
7 License: GPL
8 Group: Utilities/System
9 BuildRoot: %{_tmppath}/%{name}-root
10 Obsoletes: mdctl
11
12 %description
13 mdadm is a program that can be used to create, manage, and monitor
14 Linux MD (Software RAID) devices.
15
16 %prep
17 %setup -q
18 # we want to install in /sbin, not /usr/sbin...
19 %define _exec_prefix %{nil}
20
21 %build
22 # This is a debatable issue. The author of this RPM spec file feels that
23 # people who install RPMs (especially given that the default RPM options
24 # will strip the binary) are not going to be running gdb against the
25 # program.
26 make CXFLAGS="$RPM_OPT_FLAGS" SYSCONFDIR="%{_sysconfdir}"
27
28 %install
29 make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} BINDIR=%{_sbindir} install
30 install -D -m644 mdadm.conf-example $RPM_BUILD_ROOT/%{_sysconfdir}/mdadm.conf
31
32 %clean
33 rm -rf $RPM_BUILD_ROOT
34
35 %files
36 %defattr(-,root,root)
37 %doc TODO ChangeLog mdadm.conf-example COPYING
38 %{_sbindir}/mdadm
39 %{_sbindir}/mdmon
40 /usr/lib/udev/rules.d/63-md-raid-arrays.rules
41 /usr/lib/udev/rules.d/64-md-raid-assembly.rules
42 %config(noreplace,missingok)/%{_sysconfdir}/mdadm.conf
43 %{_mandir}/man*/md*
44
45 %changelog