mdadm: Fail for kernels older than 2.6.15
authorJes Sorensen <Jes.Sorensen@gmail.com>
Thu, 6 Apr 2017 19:46:31 +0000 (15:46 -0400)
committerJes Sorensen <Jes.Sorensen@gmail.com>
Thu, 6 Apr 2017 19:46:31 +0000 (15:46 -0400)
With the removal of old kernel API support, mdadm will no longer run
on kernels older than 2.6.15.

Signed-off-by: Jes Sorensen <Jes.Sorensen@gmail.com>
mdadm.c

diff --git a/mdadm.c b/mdadm.c
index 3fe17fc..001ff68 100644 (file)
--- a/mdadm.c
+++ b/mdadm.c
@@ -120,6 +120,11 @@ int main(int argc, char *argv[])
        ident.container = NULL;
        ident.member = NULL;
 
+       if (get_linux_version() < 2006015) {
+               pr_err("This version of mdadm does not support kernels older than 2.6.15\n");
+               exit(1);
+       }
+
        while ((option_index = -1),
               (opt = getopt_long(argc, argv, shortopt, long_options,
                                  &option_index)) != -1) {