]> git.ipfire.org Git - thirdparty/openembedded/openembedded-core-contrib.git/blame - meta/recipes-graphics/wayland/wayland_1.20.0.bb
wayland: provide wayland-client-native and wayland-protocols-native
[thirdparty/openembedded/openembedded-core-contrib.git] / meta / recipes-graphics / wayland / wayland_1.20.0.bb
CommitLineData
41538cb5
AD
1SUMMARY = "Wayland, a protocol between a compositor and clients"
2DESCRIPTION = "Wayland is a protocol for a compositor to talk to its clients \
3as well as a C library implementation of that protocol. The compositor can be \
4a standalone display server running on Linux kernel modesetting and evdev \
5input devices, an X application, or a wayland client itself. The clients can \
6be traditional applications, X servers (rootless or fullscreen) or other \
7display servers."
8HOMEPAGE = "http://wayland.freedesktop.org"
9LICENSE = "MIT"
696895e3
DD
10LIC_FILES_CHKSUM = "file://COPYING;md5=b31d8f53b6aaf2b4985d7dd7810a70d1 \
11 file://src/wayland-server.c;endline=24;md5=b8e046164a766bb1ede8ba38e9dcd7ce"
12
d821415a 13DEPENDS = "expat libffi wayland-native"
db450e6e 14
9b3d71ef 15SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
296ee10b 16 file://run-ptest \
88494d11 17 file://0002-Do-not-hardcode-the-path-to-wayland-scanner.patch \
ffa91ff1 18 file://0001-build-Fix-strndup-detection-on-MinGW.patch \
9b3d71ef 19 "
d81c8d13 20SRC_URI[sha256sum] = "b8a034154c7059772e0fdbd27dbfcda6c732df29cae56a82274f6ec5d7cd8725"
696895e3 21
8befb09e
RB
22UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
23
296ee10b 24inherit meson pkgconfig ptest
41538cb5 25
d821415a 26PACKAGECONFIG ??= "dtd-validation"
88494d11 27PACKAGECONFIG[dtd-validation] = "-Ddtd_validation=true,-Ddtd_validation=false,libxml2,,"
d821415a 28
88494d11 29EXTRA_OEMESON = "-Ddocumentation=false"
08a75519 30EXTRA_OEMESON:class-native = "-Ddocumentation=false"
41538cb5 31
97a3c3bc
RB
32# Wayland installs a M4 macro for other projects to use, which uses the target
33# pkg-config to find files. Replace pkg-config with pkg-config-native.
42344347 34do_install:append:class-native() {
97a3c3bc
RB
35 sed -e 's,PKG_CHECK_MODULES(.*),,g' \
36 -e 's,$PKG_CONFIG,pkg-config-native,g' \
37 -i ${D}/${datadir}/aclocal/wayland-scanner.m4
41538cb5 38}
ad9bd9ce 39
296ee10b
AK
40do_install_ptest() {
41 mkdir -p ${D}${PTEST_PATH}/tests/data
42 cp -rf ${B}/tests/*-test ${B}/tests/*-checker ${D}${PTEST_PATH}/tests
43 cp -rf ${B}/tests/*-checker ${D}${PTEST_PATH}
44 cp -rf ${S}/tests/scanner-test.sh ${D}${PTEST_PATH}/tests
45 cp -rf ${S}/tests/data/* ${D}${PTEST_PATH}/tests/data/
46 cp -rf ${S}/egl/wayland-egl-symbols-check ${D}${PTEST_PATH}/tests/
47}
48
42344347 49sysroot_stage_all:append:class-target () {
8f3be192 50 rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
ad9bd9ce
RP
51 cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
52}
7aeeaf28 53
a31fbec4 54PACKAGES =+ "${PN}-tools"
5e96a2b5 55
a31fbec4
TH
56FILES:${PN}-tools = "${bindir}/wayland-scanner"
57FILES:${PN}-dev += "${datadir}/${BPN}/wayland-scanner.mk"
db450e6e
AM
58
59BBCLASSEXTEND = "native nativesdk"
296ee10b 60
42344347 61RDEPENDS:${PN}-ptest += "binutils sed ${PN}-tools"