]> git.ipfire.org Git - thirdparty/pdns.git/blobdiff - builder-support/debian/recursor/debian-stretch/rules
builder: avoid config change prompts on each pdns-recursor update
[thirdparty/pdns.git] / builder-support / debian / recursor / debian-stretch / rules
index 2f0ffd17a12d7c73c95a5ea288e19c8367f89197..43099f8cf36d98f6a4c2cc11b8bbd33287c58982 100755 (executable)
@@ -2,7 +2,7 @@
 DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
 
 # Enable hardening features for daemons
-# Note: blhc (build log hardening check) will find these false positivies: CPPFLAGS 2 missing, LDFLAGS 1 missing
+# Note: blhc (build log hardening check) will find these false positives: CPPFLAGS 2 missing, LDFLAGS 1 missing
 export DEB_BUILD_MAINT_OPTIONS=hardening=+bindnow,+pie
 DPKG_EXPORT_BUILDFLAGS = 1
 # Include buildflags.mk so we can append to the vars it sets.
@@ -44,7 +44,7 @@ override_dh_auto_install:
        install -m 644 -t debian/pdns-recursor/usr/share/pdns-recursor/lua-config debian/lua-config/rootkeys.lua
        install -m 644 -t debian/pdns-recursor/etc/powerdns debian/recursor.lua
        rm -f debian/pdns-recursor/etc/powerdns/recursor.conf-dist
-       ./pdns_recursor --no-config --config | sed \
+       ./pdns_recursor --no-config --config=default | sed \
                -e 's!# config-dir=.*!config-dir=/etc/powerdns!' \
                -e 's!# include-dir=.*!&\ninclude-dir=/etc/powerdns/recursor.d!' \
                -e 's!# local-address=.*!local-address=127.0.0.1!' \
@@ -53,6 +53,7 @@ override_dh_auto_install:
                -e 's!# setgid=.*!setgid=pdns!' \
                -e 's!# setuid=.*!setuid=pdns!' \
                -e 's!# hint-file=.*!&\nhint-file=/usr/share/dns/root.hints!' \
+               -e '/^# version-string=.*/d' \
                > debian/pdns-recursor/etc/powerdns/recursor.conf
 
 override_dh_strip: