]> git.ipfire.org Git - thirdparty/pdns.git/blobdiff - pdns/dnsdistdist/Makefile.am
mplexer: Add some unit tests for our multiplexers
[thirdparty/pdns.git] / pdns / dnsdistdist / Makefile.am
index 8c9e90b5cd55a5cfc1031664bd0f324b3f205584..b827fe03c0cb05fc626d95e2d4355eb84bced9ac 100644 (file)
@@ -213,20 +213,6 @@ dnsdist.$(OBJEXT): dnsmessage.pb.cc dnstap.pb.cc
 endif
 endif
 
-if HAVE_FREEBSD
-dnsdist_SOURCES += kqueuemplexer.cc
-endif
-
-if HAVE_LINUX
-dnsdist_SOURCES += epollmplexer.cc
-endif
-
-if HAVE_SOLARIS
-dnsdist_SOURCES += \
-        devpollmplexer.cc \
-        portsmplexer.cc
-endif
-
 testrunner_SOURCES = \
        base64.hh \
        dns.hh \
@@ -240,6 +226,7 @@ testrunner_SOURCES = \
        test-dnsdistrules_cc.cc \
        test-dnsparser_cc.cc \
        test-iputils_hh.cc \
+       test-mplexer.cc \
        cachecleaner.hh \
        dnsdist.hh \
        dnsdist-cache.cc dnsdist-cache.hh \
@@ -259,6 +246,7 @@ testrunner_SOURCES = \
        misc.cc misc.hh \
        namespaces.hh \
        pdnsexception.hh \
+       pollmplexer.cc \
        qtype.cc qtype.hh \
        sholder.hh \
        sodcrypto.cc \
@@ -268,6 +256,25 @@ testrunner_SOURCES = \
        testrunner.cc \
        xpf.cc xpf.hh
 
+if HAVE_FREEBSD
+dnsdist_SOURCES += kqueuemplexer.cc
+testrunner_SOURCES += kqueuemplexer.cc
+endif
+
+if HAVE_LINUX
+dnsdist_SOURCES += epollmplexer.cc
+testrunner_SOURCES += epollmplexer.cc
+endif
+
+if HAVE_SOLARIS
+dnsdist_SOURCES += \
+        devpollmplexer.cc \
+        portsmplexer.cc
+testrunner_SOURCES += \
+        devpollmplexer.cc \
+        portsmplexer.cc
+endif
+
 testrunner_LDFLAGS = \
        $(AM_LDFLAGS) \
        $(PROGRAM_LDFLAGS) \