]> git.ipfire.org Git - thirdparty/rrdtool-1.x.git/blame - rrdtool.spec
Create codeql-analysis.yml
[thirdparty/rrdtool-1.x.git] / rrdtool.spec
CommitLineData
af65fcfe
TO
1%define with_python %{?_without_python: 0} %{?!_without_python: 1}
2%define with_php %{?_without_php: 0} %{?!_without_php: 1}
3%define with_tcl %{?_without_tcl: 0} %{?!_without_tcl: 1}
4%define with_ruby %{?_without_ruby: 0} %{?!_without_ruby: 1}
34ac1126 5%define with_lua %{?_without_lua: 0} %{?!_without_lua: 1}
57a9064b 6%define with_systemd %{?_without_systemd: 0} %{?!_without_systemd: 1}
af65fcfe 7%define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
daf615d6 8%define svnrev r1190
daf615d6 9#define pretag 1.2.99908020600
668923b9 10%define rrdcached_user rrdcached
af65fcfe 11
95f9c697 12Summary: Round Robin Database Tool to store and display time-series data
6aa682e9 13Name: rrdtool
8e6915c6 14Version: 1.7.2
34ac1126 15Release: 1%{?dist}
daf615d6 16License: GPLv2+ with exceptions
d43d8a55 17Group: Applications/Databases
267369f9
WS
18URL: https://oss.oetiker.ch/rrdtool/
19#Source0: https://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
20Source0: https://oss.oetiker.ch/rrdtool/pub/beta/%{name}-%{version}.tar.gz
be3b9356 21%if %{with_php}
daf615d6
TO
22Source1: php4-%{svnrev}.tar.gz
23Patch1: rrdtool-1.3.0-beta4-fix-rrd_update-in-php-bindings.patch
be3b9356 24%endif
21e777b4 25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
daf615d6 26Requires: dejavu-lgc-fonts
af65fcfe 27BuildRequires: gcc-c++, openssl-devel, freetype-devel
daf615d6 28BuildRequires: libpng-devel, zlib-devel, intltool >= 0.35.0
507e8bda 29BuildRequires: cairo-devel >= 1.2, pango-devel >= 1.14
daf615d6
TO
30BuildRequires: libtool, groff
31BuildRequires: gettext, libxml2-devel
32%if 0%{?fedora} >= 7
33BuildRequires: perl-ExtUtils-MakeMaker perl-devel
af65fcfe 34%endif
37fc6638
TO
35
36%description
21e777b4
TO
37RRD is the Acronym for Round Robin Database. RRD is a system to store and
38display time-series data (i.e. network bandwidth, machine-room temperature,
39server load average). It stores the data in a very compact way that will not
40expand over time, and it presents useful graphs by processing the data to
41enforce a certain data density. It can be used either via simple wrapper
42scripts (from shell or Perl) or via frontends that poll network devices and
95f9c697 43put a friendly user interface on it.
37fc6638 44
6aa682e9 45%package devel
21e777b4 46Summary: RRDtool libraries and header files
6aa682e9 47Group: Development/Libraries
21e777b4 48Requires: %{name} = %{version}-%{release}
6aa682e9
TO
49
50%description devel
95f9c697
TO
51RRD is the Acronym for Round Robin Database. RRD is a system to store and
52display time-series data (i.e. network bandwidth, machine-room temperature,
53server load average). This package allow you to use directly this library.
6aa682e9 54
21e777b4
TO
55%package doc
56Summary: RRDtool documentation
57Group: Documentation
58
59%description doc
60RRD is the Acronym for Round Robin Database. RRD is a system to store and
61display time-series data (i.e. network bandwidth, machine-room temperature,
62server load average). This package contains documentation on using RRD.
63
34ac1126
TO
64%define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
65%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
66
af65fcfe 67%package perl
95f9c697
TO
68Summary: Perl RRDtool bindings
69Group: Development/Languages
21e777b4 70Requires: %{name} = %{version}-%{release}
af65fcfe
TO
71Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
72Obsoletes: perl-%{name} < %{version}-%{release}
73Provides: perl-%{name} = %{version}-%{release}
6aa682e9 74
af65fcfe 75%description perl
95f9c697 76The Perl RRDtool bindings
6aa682e9 77
af65fcfe
TO
78%if %{with_python}
79%{!?python_sitearch: %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')}
80# eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
81%{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
82
83%package python
95f9c697
TO
84Summary: Python RRDtool bindings
85Group: Development/Languages
af65fcfe 86BuildRequires: python-devel >= 2.3
95f9c697 87Requires: python >= %{python_version}
21e777b4 88Requires: %{name} = %{version}-%{release}
af65fcfe
TO
89Obsoletes: python-%{name} < %{version}-%{release}
90Provides: python-%{name} = %{version}-%{release}
3f437d5c 91
af65fcfe 92%description python
95f9c697 93Python RRDtool bindings.
af65fcfe
TO
94%endif
95
96%ifarch ppc64
97# php bits busted on ppc64 at the moment
98%define with_php 0
99%endif
100
101%if %{with_php}
102%package php
103Summary: PHP RRDtool bindings
104Group: Development/Languages
105BuildRequires: php-devel >= 4.0
106Requires: php >= 4.0
107Requires: %{name} = %{version}-%{release}
daf615d6
TO
108%if 0%{?php_zend_api}
109Requires: php(zend-abi) = %{php_zend_api}
110Requires: php(api) = %{php_core_api}
111%else
112Requires: php-api = %{php_apiver}
113%endif
af65fcfe
TO
114Obsoletes: php-%{name} < %{version}-%{release}
115Provides: php-%{name} = %{version}-%{release}
daf615d6 116Provides: php-pecl(rrdtool)
af65fcfe
TO
117
118%description php
119The %{name}-php package includes a dynamic shared object (DSO) that adds
120RRDtool bindings to the PHP HTML-embedded scripting language.
121%endif
122
123%if %{with_tcl}
124%package tcl
125Summary: Tcl RRDtool bindings
126Group: Development/Languages
127BuildRequires: tcl-devel >= 8.0
128Requires: tcl >= 8.0
129Requires: %{name} = %{version}-%{release}
130Obsoletes: tcl-%{name} < %{version}-%{release}
131Provides: tcl-%{name} = %{version}-%{release}
132
133%description tcl
134The %{name}-tcl package includes RRDtool bindings for Tcl.
135%endif
136
137%if %{with_ruby}
138%{!?ruby_sitearch: %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')}
139
140%package ruby
141Summary: Ruby RRDtool bindings
142Group: Development/Languages
143BuildRequires: ruby, ruby-devel
144Requires: ruby(abi) = 1.8
145Requires: %{name} = %{version}-%{release}
146
147%description ruby
148The %{name}-ruby package includes RRDtool bindings for Ruby.
149%endif
95f9c697 150
34ac1126
TO
151%if %{with_lua}
152%{!?lua_version: %define lua_version %(lua -v 2>&1 | cut -f2 -d' ' | cut -f1,2 -d '.')}
153
154%package lua
155Summary: Lua RRDtool bindings
156Group: Development/Languages
157BuildRequires: lua-devel
158Requires: lua
159Requires: %{name} = %{version}-%{release}
160
161%description lua
162The %{name}-lua package includes RRDtool bindings for Lua.
163%endif
164
668923b9
TO
165%package cached
166Summary: Data caching daemon for RRDtool
167Group: Applications/Databases
168Requires: %{name} = %{version}-%{release}
57a9064b
TV
169%if %{with_systemd}
170BuildRequires: with_systemd
171%endif
668923b9
TO
172
173%description cached
174rrdcached is a daemon that receives updates to existing RRD files,
175accumulates them and, if enough have been received or a defined time has
176passed, writes the updates to the RRD file. The daemon was written with
177big setups in mind which usually runs into I/O related problems. This
178daemon was written to alleviate these problems.
179
3f437d5c 180%prep
af65fcfe 181%if %{with_php}
507e8bda 182%setup -q -n %{name}-%{version} -a 1
daf615d6 183%patch1 -p1
be3b9356 184%else
507e8bda 185%setup -q -n %{name}-%{version}
af65fcfe 186%endif
6aa682e9 187
21e777b4
TO
188# Fix to find correct python dir on lib64
189%{__perl} -pi -e 's|get_python_lib\(0,0,prefix|get_python_lib\(1,0,prefix|g' \
190 configure
191
af65fcfe 192# Most edits shouldn't be necessary when using --libdir, but
daf615d6 193# w/o, some introduce hardcoded rpaths where they shouldn't
be3b9356
TO
194%{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' configure Makefile.in*
195%if %{with_php}
196%{__perl} -pi.orig -e 's|/lib\b|/%{_lib}|g' php4/configure php4/ltconfig*
197%endif
6aa682e9 198
daf615d6
TO
199# Perl 5.10 seems to not like long version strings, hack around it
200%{__perl} -pi.orig -e 's|1.299907080300|1.29990708|' \
201 bindings/perl-shared/RRDs.pm bindings/perl-piped/RRDp.pm
202
203#
204# fix config files for php4 bindings
205# workaround needed due to https://bugzilla.redhat.com/show_bug.cgi?id=211069
be3b9356 206%if %{with_php}
daf615d6 207cp -p /usr/lib/rpm/config.{guess,sub} php4/
be3b9356
TO
208%endif
209
daf615d6 210
37fc6638 211%build
95f9c697 212%configure \
507e8bda 213 CFLAGS="-g -O0" \
af65fcfe
TO
214 --with-perl-options='INSTALLDIRS="vendor"' \
215%if %{with_tcl}
216 --enable-tcl-site \
217 --with-tcllib=%{_libdir} \
218%else
219 --disable-tcl \
220%endif
221%if %{with_python}
222 --enable-python \
223%else
224 --disable-python \
225%endif
226%if %{with_ruby}
227 --enable-ruby \
34ac1126
TO
228%else
229 --disable-ruby \
af65fcfe 230%endif
34ac1126
TO
231%if %{with_lua}
232 --enable-lua \
233%else
234 --disable-lua \
235%endif
236 --enable-perl-site-install \
21e777b4 237 --disable-static \
af65fcfe 238 --with-pic
21e777b4
TO
239
240# Fix another rpath issue
241%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
242 bindings/perl-shared/Makefile.PL
243
daf615d6
TO
244#{__make} %{?_smp_mflags}
245make
37fc6638 246
af65fcfe
TO
247# Build the php module, the tmp install is required
248%if %{with_php}
249%define rrdtmp %{_tmppath}/%{name}-%{version}-tmpinstall
250%{__make} install DESTDIR="%{rrdtmp}"
251pushd php4/
252%configure \
253 --with-rrdtool="%{rrdtmp}%{_prefix}" \
254 --disable-static
daf615d6
TO
255#{__make} %{?_smp_mflags}
256make
af65fcfe
TO
257popd
258%{__rm} -rf %{rrdtmp}
259%endif
260
21e777b4
TO
261# Fix @perl@ and @PERL@
262find examples/ -type f \
263 -exec %{__perl} -pi -e 's|^#! \@perl\@|#!%{__perl}|gi' {} \;
264find examples/ -name "*.pl" \
265 -exec %{__perl} -pi -e 's|\015||gi' {} \;
266
37fc6638 267%install
21e777b4
TO
268rm -rf $RPM_BUILD_ROOT
269make DESTDIR="$RPM_BUILD_ROOT" install
37fc6638 270
af65fcfe
TO
271# Install the php module
272%if %{with_php}
273%{__install} -D -m0755 php4/modules/rrdtool.so \
274 %{buildroot}%{php_extdir}/rrdtool.so
275# Clean up the examples for inclusion as docs
276%{__rm} -rf php4/examples/.svn
277# Put the php config bit into place
278%{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
279%{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/rrdtool.ini
280; Enable rrdtool extension module
281extension=rrdtool.so
282__EOF__
283%endif
284
21e777b4
TO
285# We only want .txt and .html files for the main documentation
286%{__mkdir_p} doc2/html doc2/txt
287%{__cp} -a doc/*.txt doc2/txt/
288%{__cp} -a doc/*.html doc2/html/
95f9c697 289
21e777b4
TO
290# Put perl docs in perl package
291%{__mkdir_p} doc3/html
292%{__mv} doc2/html/RRD*.html doc3/html/
95f9c697 293
21e777b4
TO
294# Clean up the examples
295%{__rm} -f examples/Makefile* examples/*.in
6aa682e9 296
21e777b4
TO
297# This is so rpm doesn't pick up perl module dependencies automatically
298find examples/ -type f -exec chmod 0644 {} \;
3f437d5c 299
21e777b4 300# Clean up the buildroot
daf615d6 301%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-* \
21e777b4
TO
302 $RPM_BUILD_ROOT%{perl_vendorarch}/ntmake.pl \
303 $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod \
304 $RPM_BUILD_ROOT%{_datadir}/%{name}/examples \
305 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/*/{.packlist,*.bs}
95f9c697 306
507e8bda
TO
307# Set up rrdcached
308%__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/default
309%__install -d -m 0755 $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d
755ef73c
PB
310%__install -m 0644 etc/rrdcached-default-redhat $RPM_BUILD_ROOT/%{_sysconfdir}/default/rrdcached
311%__install -m 0755 etc/rrdcached-init-redhat $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/rrdcached
507e8bda
TO
312%__install -d -m 0755 -o nobody -g nobody $RPM_BUILD_ROOT/%{_localstatedir}/run/rrdcached
313
21e777b4
TO
314%clean
315%{__rm} -rf $RPM_BUILD_ROOT
95f9c697 316
668923b9
TO
317%pre cached
318/usr/sbin/groupadd %rrdcached_user &>/dev/null ||:
319/usr/sbin/useradd -s /sbin/nologin -g %rrdcached_user -c %rrdcached_user -d %{_localstatedir}/run/rrdcached %rrdcached_user &>/dev/null || :
320
321%post -p /sbin/ldconfig
322
323%post cached
57a9064b
TV
324%if %{with_systemd}
325 %systemd_post rrdcached.service
326 %systemd_post rrdcached.socket
327%else
328 /sbin/chkconfig --add rrdcached || :
329 if [ $1 -lt 2 ] # Installing
330 then
331 /sbin/service rrdcached start || :
332 else # Upgrading
333 /sbin/service rrdcached restart || :
334 fi
335%endif
d5deead0 336
57a9064b
TV
337%posttrans cached
338%if %{with_systemd}
339%else
340 /sbin/chkconfig --add rrdcached || :
341 /sbin/service rrdcached restart || :
342%endif
507e8bda 343
668923b9 344%preun cached
57a9064b
TV
345%if %{with_systemd}
346 %systemd_preun rrdcached.service
347 %systemd_preun rrdcached.socket
348%else
349 if [ $1 -lt 1 ] # Uninstalling
350 then
351 /sbin/service rrdcached stop || :
352 fi
353%endif
95f9c697 354
668923b9 355%postun -p /sbin/ldconfig
95f9c697 356
668923b9 357%postun cached
57a9064b
TV
358%if %{with_systemd}
359 %systemd_postun_with_restart rrdcached.service
360 %systemd_postun_with_restart rrdcached.socket
361%else
362 if [ $1 -lt 1 ] # Uninstalling
363 then
364 /usr/sbin/userdel %rrdcached_user &>/dev/null || :
365 fi
366%endif
668923b9 367
21e777b4 368%files
af65fcfe 369%defattr(-,root,root,-)
21e777b4 370%{_bindir}/*
668923b9 371%exclude %{_bindir}/rrdcached
21e777b4 372%{_libdir}/*.so.*
af65fcfe 373%{_datadir}/%{name}
21e777b4 374%{_mandir}/man1/*
668923b9 375%exclude %{_mandir}/man1/rrdcached*
95f9c697 376
21e777b4
TO
377%files devel
378%defattr(-,root,root,-)
379%{_includedir}/*.h
380%exclude %{_libdir}/*.la
381%{_libdir}/*.so
d46cfe08 382%{_libdir}/pkgconfig/librrd.pc
21e777b4
TO
383
384%files doc
385%defattr(-,root,root,-)
daf615d6 386%doc CONTRIBUTORS COPYING COPYRIGHT README TODO NEWS THREADS
af65fcfe 387%doc examples doc2/html doc2/txt
21e777b4 388
af65fcfe 389%files perl
21e777b4
TO
390%defattr(-,root,root,-)
391%doc doc3/html
392%{_mandir}/man3/*
393%{perl_vendorarch}/*.pm
af65fcfe 394%attr(0755,root,root) %{perl_vendorarch}/auto/RRDs/
34ac1126 395%{perl_vendorlib}/*.pm
21e777b4 396
af65fcfe
TO
397%if %{with_python}
398%files python
21e777b4
TO
399%defattr(-,root,root,-)
400%doc bindings/python/AUTHORS bindings/python/COPYING bindings/python/README
06a871af 401%{python_sitearch}/*
af65fcfe
TO
402%endif
403
404%if %{with_php}
405%files php
406%defattr(-,root,root,0755)
407%doc php4/examples php4/README
408%config(noreplace) %{_sysconfdir}/php.d/rrdtool.ini
409%{php_extdir}/rrdtool.so
410%endif
411
412%if %{with_tcl}
413%files tcl
414%defattr(-,root,root,-)
415%doc bindings/tcl/README
416%{_libdir}/tclrrd*.so
417%{_libdir}/rrdtool/*.tcl
418%endif
419
420%if %{with_ruby}
421%files ruby
422%defattr(-,root,root,-)
423%doc bindings/ruby/README
424%{ruby_sitearch}/RRD.so
425%endif
95f9c697 426
34ac1126
TO
427%if %{with_lua}
428%files lua
429%defattr(-,root,root,-)
430%{_libdir}/lua/%{lua_version}/rrd.*
431%endif
432
668923b9
TO
433%files cached
434%{_bindir}/rrdcached
435%config %{_sysconfdir}/default/*
436%config %{_sysconfdir}/rc.d/init.d/*
437%{_mandir}/man1/rrdcached*
438%attr(0775 %rrdcached_user %rrdcached_user) %dir %{_localstatedir}/run/rrdcached
57a9064b
TV
439%if %{with_systemd}
440%{_unitdir}/rrdcached.service
441%{_unitdir}/rrdcached.socket
442%endif
668923b9 443
21e777b4 444%changelog
57a9064b
TV
445* Wed Mar 01 2017 Tomas Vestelind <tomas.vestelind@gmail.com>
446- systemd preset logic for rrdcached
447
34ac1126
TO
448* Tue Jan 25 2011 Bernard Li <bernard@vanhpc.org>
449- Reset Release to 1
450- Add -lua subpackage
451- Fix -perl subpackage so it includes the correct Perl package paths
452
668923b9
TO
453* Wed Oct 08 2008 Bernard Li <bernard@vanhpc.org>
454- Split rrdcached related files to -cached subpackage
455- Create rrdcached user and make rrdcached related files owned by it
456
d46cfe08
TO
457* Tue Oct 07 2008 Bernard Li <bernard@vanhpc.org>
458- Include librrd.pc file in -devel package
459
daf615d6
TO
460* Sun Jun 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.20.rc9
461- Update to rrdtool 1.3 rc9
462- Minor spec tweaks to permit building on older EL
463
464* Wed Jun 04 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.19.rc7
465- Update to rrdtool 1.3 rc7
466
467* Tue May 27 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.18.rc6
468- Update to rrdtool 1.3 rc6
469
470* Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.17.rc4
471- Bump version and rebuild
472
473* Wed May 21 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.16.rc4
474- Fix php bindings compile on x86_64
475
476* Mon May 19 2008 Chris Ricker <kaboom@oobleck.net> 1.3-0.15.rc4
477- Update to rrdtool 1.3 rc4
478
479* Tue May 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.15.rc1
480- Update to rrdtool 1.3 rc1
481- Fix versioning in changelog entries, had an extra 0 in there...
482- Drop cairo and python patches, they're in 1.3 rc1
483- Add Requires: gettext and libxml2-devel for new translations
484
485* Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.14.beta4
486- Drop some conditional flags, they're not working at the moment...
487
488* Wed Apr 30 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.13.beta4
489- Fix problem with cairo_save/cairo_restore (#444827)
490
491* Wed Apr 23 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.12.beta4
492- Fix python bindings rrdtool info implementation (#435468)
493
494* Tue Apr 08 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.11.beta4
495- Work around apparent version string length issue w/perl 5.10 (#441359)
496
497* Sat Apr 05 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.10.beta4
498- Fix use of rrd_update in php bindings (#437558)
499
500* Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.9.beta4
501- rebuild for new perl (again)
502
503* Wed Feb 13 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.8.beta4
504- Update to rrdtool 1.3 beta4
505
506* Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.3-0.7.beta3
507- rebuild for new perl (and fix license tag)
508
509* Mon Feb 04 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.6.beta3
510- Plug memory leak (#430879)
511
512* Mon Jan 07 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.5.beta3
513- Fix right-aligned text alignment and scaling (Resolves: #427609)
514
515* Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.4.beta3
516- Add newly built python egg to %%files
517
518* Wed Jan 02 2008 Jarod Wilson <jwilson@redhat.com> 1.3-0.3.beta3
519- Update to rrdtool 1.3 beta3
520- Return properly from errors in RRDp.pm (Resolves: #427040)
521- Requires: dejavu-lgc-fonts (Resolves: #426935)
522
523* Thu Dec 06 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.2.beta2
524- Update to rrdtool 1.3 beta2
525
526* Wed Aug 08 2007 Jarod Wilson <jwilson@redhat.com> 1.3-0.1.beta1
527- Update to rrdtool 1.3 beta1
528
529* Tue Jul 10 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.3.r1144
530- Update to latest rrdtool pre-1.3 svn snapshot (svn r1144)
531- Add php abi check (Resolves: #247339)
532
533* Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.2.r1127
534- Fix up BuildRequires
535
536* Fri Jun 15 2007 Jarod Wilson <jwilson@redhat.com> 1.2.999-0.1.r1127
537- Update to rrdtool pre-1.3 svn snapshot (svn r1127)
af65fcfe
TO
538
539* Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-5
540- BR: ruby so %%ruby_sitearch gets set
541
542* Mon May 21 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-4
543- Build ruby bindings
544
545* Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-3
546- Disable php bits on ppc64 for now, they fail to build
547
548* Thu May 03 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-2
549- Add BR: perl-devel for Fedora 7 and later
550
551* Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.23-1
552- New upstream release
553
554* Tue May 01 2007 Jarod Wilson <jwilson@redhat.com> 1.2.21-1
555- New upstream release
556
557* Wed Apr 25 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-2
558- Define %%python_version *before* its needed (#237826)
559
560* Mon Apr 09 2007 Jarod Wilson <jwilson@redhat.com> 1.2.19-1
561- New upstream release
562
563* Tue Jan 23 2007 Jarod Wilson <jwilson@redhat.com> 1.2.18-1
564- New upstream release
565
566* Mon Jan 22 2007 Jarod Wilson <jwilson@redhat.com> 1.2.17-1
567- New upstream release
568
569* Tue Jan 02 2007 Jarod Wilson <jwilson@redhat.com> 1.2.15-9
570- Fix crash with long error strings (upstream
571 changesets 929 and 935)
572
573* Thu Dec 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-8
574- Fix for log grid memory leak (#201241)
575
576* Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-7
577- Rebuild for python 2.5
578
579* Tue Nov 14 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-6
580- Conditionalize python, php and tcl bits (Resolves #203275)
581
582* Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-5
583- Add tcl sub-package (#203275)
584
585* Tue Sep 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-4
586- Rebuild for new glibc
587
588* Wed Aug 02 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-3
589- One more addition to initrrdtool patch, to fully revert
590 and correct upstream changeset 839
591- Fix for no python in minimal fc4 buildroots
592
593* Tue Aug 1 2006 Mihai Ibanescu <misa@redhat.com> 1.2.15-2
594- Fixed rrdtool-python to import the module properly (patch
595 rrdtool-1.2.15-initrrdtool.patch)
596
597* Mon Jul 17 2006 Jarod Wilson <jwilson@redhat.com> 1.2.15-1
598- Update to 1.2.15
599- Minor spec cleanups
600
601* Sat Jun 24 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-7
602- Fix up Obsoletes
603
604* Mon Jun 19 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-6
605- Flip perl, php and python sub-package names around to
606 conform with general practices
607
608* Sat Jun 10 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-5
609- Minor fixes to make package own created directories
610
611* Wed Jun 07 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-4
612- Add php bits back into the mix
613
21e777b4
TO
614* Mon Jun 05 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-3
615- Merge spec fixes from bz 185909
616
617* Sun Jun 04 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-2
618- Remove explicit perl dep, version grabbing using rpm during
619 rpmbuild not guaranteed to work (fails on ppc in plague),
620 and auto-gen perl deps are sufficient
621
622* Sat Jun 03 2006 Jarod Wilson <jwilson@redhat.com> 1.2.13-1
623- Update to release 1.2.13
624- Merge spec changes from dag, atrpms and mdk builds
625- Additional hacktastic contortions for lib64 & rpath messiness
626- Add missing post/postun ldconfig
627- Fix a bunch of rpmlint errors
628- Disable static libs, per FE guidelines
629- Split off docs
630
631* Wed Apr 19 2006 Chris Ricker <kaboom@oobleck.net> 1.2.12-1
632- Rev to 1.2
633
634* Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-5
635- Include patch from Michael to fix perl module compilation on FC4 (#156242).
636
637* Fri May 20 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-4
638- Fix for the php module patch (Joe Pruett, Dag Wieers), #156716.
639- Update source URL to new location since 1.2 is now the default stable.
640- Don't (yet) update to 1.0.50, as it introduces some changes in the perl
641 modules install.
642
643* Mon Jan 31 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-3
644- Put perl modules in vendor_perl and not site_perl. #146513
645
646* Thu Jan 13 2005 Matthias Saou <http://freshrpms.net/> 1.0.49-2
647- Minor cleanups.
95f9c697
TO
648
649* Thu Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.49-1
650- Updated to release 1.0.49.
651
652* Wed Aug 25 2004 Dag Wieers <dag@wieers.com> - 1.0.48-3
653- Fixes for x86_64. (Garrick Staples)
654
655* Fri Jul 2 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-3
656- Actually apply the patch for fixing the php module, doh!
657
658* Thu May 27 2004 Matthias Saou <http://freshrpms.net/> 1.0.48-2
659- Added php.d config entry to load the module once installed.
660
661* Thu May 13 2004 Dag Wieers <dag@wieers.com> - 1.0.48-1
662- Updated to release 1.0.48.
663
664* Tue Apr 06 2004 Dag Wieers <dag@wieers.com> - 1.0.47-1
665- Updated to release 1.0.47.
666
667* Thu Mar 4 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-2
668- Change the strict dependency on perl to fix problem with the recent
669 update.
670
671* Mon Jan 5 2004 Matthias Saou <http://freshrpms.net/> 1.0.46-1
672- Update to 1.0.46.
673- Use system libpng and zlib instead of bundled ones.
674- Added php-rrdtool sub-package for the php4 module.
675
676* Fri Dec 5 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-4
677- Added epoch to the perl dependency to work with rpm > 4.2.
678- Fixed the %% escaping in the perl dep.
679
680* Mon Nov 17 2003 Matthias Saou <http://freshrpms.net/> 1.0.45-2
681- Rebuild for Fedora Core 1.
682
683* Sun Aug 3 2003 Matthias Saou <http://freshrpms.net/>
684- Update to 1.0.45.
685
686* Wed Apr 16 2003 Matthias Saou <http://freshrpms.net/>
687- Update to 1.0.42.
688
689* Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
690- Rebuilt for Red Hat Linux 9.
691
692* Wed Mar 5 2003 Matthias Saou <http://freshrpms.net/>
693- Added explicit perl version dependency.
694
695* Sun Feb 23 2003 Matthias Saou <http://freshrpms.net/>
696- Update to 1.0.41.
697
698* Fri Jan 31 2003 Matthias Saou <http://freshrpms.net/>
699- Update to 1.0.40.
700- Spec file cleanup.
701
702* Fri Jul 05 2002 Henri Gomez <hgomez@users.sourceforge.net>
703- 1.0.39
704
705* Mon Jun 03 2002 Henri Gomez <hgomez@users.sourceforge.net>
706- 1.0.38
707
708* Fri Apr 19 2002 Henri Gomez <hgomez@users.sourceforge.net>
709- 1.0.37
710
711* Tue Mar 12 2002 Henri Gomez <hgomez@users.sourceforge.net>
712- 1.0.34
713- rrdtools include zlib 1.1.4 which fix vulnerabilities in 1.1.3
714