]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] add ability to have up to 5 SYSFS_ file/value pairs for the LABEL rule.
[thirdparty/systemd.git] / udev.spec
CommitLineData
3660f0b8
PM
1Summary: A userspace implementation of devfs
2Name: udev
9c23ec09 3Version: 009_bk
3660f0b8
PM
4Release: 1
5License: GPL
6Group: Utilities/System
7Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
8ExclusiveOS: Linux
e0929206 9Vendor: Greg Kroah-Hartman <greg@kroah.com>
4360a56d 10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 11Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
12
13%description
14udev is a implementation of devfs in userspace using sysfs and
22120496 15/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
16
17%prep
bbab56ba 18%setup -q
3660f0b8
PM
19
20%build
bbab56ba 21make CC="gcc $RPM_OPT_FLAGS"
3660f0b8
PM
22
23%install
4360a56d 24make DESTDIR=$RPM_BUILD_ROOT install
3660f0b8 25
316c5150 26%post
27/sbin/chkconfig --add udev
28
600ee7f7 29%postun
30if [ $1 = 0 ]; then
31 /sbin/chkconfig --del udev
32fi
33
3660f0b8 34%clean
bbab56ba 35rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
36
37%files
bbab56ba
RL
38%defattr(0644,root,root)
39%doc COPYING README TODO ChangeLog
40%attr(755,root,root) /sbin/udev
41%attr(755,root,root) /udev/
42%attr(755,root,root) /etc/udev/
1b1dbc47 43%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
44%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
45%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
8634e6d1 46%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 47%attr(755,root,root) /etc/init.d/udev
bbab56ba 48%attr(0644,root,root) %{_mandir}/man8/udev.8*
3660f0b8
PM
49
50%changelog
316c5150 51* Tue Dec 16 2003 Robert Love <rml@ximian.com>
52- install the initscript and run chkconfig on it
53
e8baccca
GKH
54* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
55- changes due to config file name changes
56
bbab56ba
RL
57* Fri Oct 17 2003 Robert Love <rml@tech9.net>
58- Make work without a build root
59- Correctly install the right files
60- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
61- Put some prereqs in
8634e6d1 62- Install the hotplug symlink to udev
bbab56ba 63
3660f0b8
PM
64* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
65- Initial spec file for udev-0.2.
66