]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] udev - safer string handling all over the place
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
0c675896
GKH
14# if we want to build DBUS support in or not.
15# 0 - no DBUS support
16# 1 - DBUS support
17%define dbus 0
18
19# if we want to enable debugging support in udev. If it is enabled, lots of
20# stuff will get sent to the debug syslog.
21# 0 - debugging disabled
22# 1 - debugging enabled
23%define debug 0
24
e64280b8 25# if we want to use the LSB version of the init script or the Redhat one
e68582be
GKH
26# 0 - use Redhat: etc/init.d/udev
27# 1 - use LSB: etc/init.d/udev.init.LSB
e64280b8 28%define lsb 0
29
ca8e992c
GKH
30# if we want to build the scsi_id "extra" package or not
31# 0 - do not build the package
32# 1 - build it
33%define scsi_id 1
34
3660f0b8
PM
35Summary: A userspace implementation of devfs
36Name: udev
d54fe24c 37Version: 018_bk
3660f0b8
PM
38Release: 1
39License: GPL
40Group: Utilities/System
41Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42ExclusiveOS: Linux
e0929206 43Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 44URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 45BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 46Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
47
48%description
49udev is a implementation of devfs in userspace using sysfs and
22120496 50/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
51
52%prep
bbab56ba 53%setup -q
3660f0b8
PM
54
55%build
0c675896
GKH
56make CC="gcc $RPM_OPT_FLAGS" \
57%if %{klibc}
58 USE_KLIBC=true \
59%endif
05230184
GKH
60%if %{log}
61 USE_LOG=true \
1659326d
GKH
62%else
63 USE_LOG=false \
05230184 64%endif
0c675896
GKH
65%if %{dbus}
66 USE_DBUS=true \
1659326d
GKH
67%else
68 USE_DBUS=false \
0c675896
GKH
69%endif
70%if %{debug}
71 DEBUG=true \
1659326d
GKH
72%else
73 DEBUG=false \
0c675896 74%endif
ca8e992c
GKH
75 EXTRAS=" \
76%if %{scsi_id}
77 extras/scsi_id \
78%endif
79"
d83a9b89 80
3660f0b8 81%install
5bfabc59 82make DESTDIR=$RPM_BUILD_ROOT install \
83%if %{dbus}
e68582be
GKH
84 USE_DBUS=true \
85%else
86 USE_DBUS=false \
5bfabc59 87%endif
e64280b8 88%if %{lsb}
e68582be
GKH
89 USE_LSB=true \
90%else
91 USE_LSB=false \
e64280b8 92%endif
ca8e992c
GKH
93 EXTRAS=" \
94%if %{scsi_id}
95 extras/scsi_id \
96%endif
97"
e68582be 98
316c5150 99%post
100/sbin/chkconfig --add udev
101
600ee7f7 102%postun
103if [ $1 = 0 ]; then
104 /sbin/chkconfig --del udev
105fi
106
3660f0b8 107%clean
bbab56ba 108rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
109
110%files
ee156981 111%defattr(-,root,root)
ca8e992c 112%doc COPYING README TODO ChangeLog HOWTO* etc/udev/udev.rules.examples docs/*
bbab56ba 113%attr(755,root,root) /sbin/udev
da1cc7cc 114%attr(755,root,root) /sbin/udevinfo
d83a9b89
GKH
115%attr(755,root,root) /sbin/udevsend
116%attr(755,root,root) /sbin/udevd
e68582be
GKH
117%attr(755,root,root) /sbin/udevtest
118%attr(755,root,root) %dir /udev/
119%attr(755,root,root) %dir /etc/udev/
1b1dbc47 120%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
121%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
122%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
8634e6d1 123%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 124%attr(755,root,root) /etc/init.d/udev
567f6d14 125%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3660f0b8 126
ca8e992c
GKH
127%if %{dbus}
128 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
129%endif
130
131%if %{scsi_id}
132 %attr(755,root,root) /sbin/scsi_id
133 %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
134 %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
135%endif
136
3660f0b8 137%changelog
ca8e992c
GKH
138* Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
139- add some more files to the documentation directory
140- add ability to build scsi_id and make it the default
141
e68582be
GKH
142* Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
143- fix up udevd build, as it's no longer needed to be build seperatly
144- add udevtest to list of files
145- more Red Hat sync ups.
146
1659326d
GKH
147* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
148- add some changes from the latest Fedora udev release.
149
d83a9b89
GKH
150* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
151- add udevsend, and udevd to the files
152- add ability to build udevd with glibc after the rest is build with klibc
153
da1cc7cc 154* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 155- added udevinfo to rpm
8fc34188 156- added URL to spec file
567f6d14 157- added udevinfo's man page
da1cc7cc 158
e64280b8 159* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
160- add defines to choose the init script (Redhat or LSB)
161
316c5150 162* Tue Dec 16 2003 Robert Love <rml@ximian.com>
163- install the initscript and run chkconfig on it
164
e8baccca
GKH
165* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
166- changes due to config file name changes
167
bbab56ba
RL
168* Fri Oct 17 2003 Robert Love <rml@tech9.net>
169- Make work without a build root
170- Correctly install the right files
171- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
172- Put some prereqs in
8634e6d1 173- Install the hotplug symlink to udev
bbab56ba 174
3660f0b8
PM
175* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
176- Initial spec file for udev-0.2.