]> git.ipfire.org Git - thirdparty/systemd.git/blame - udev.spec
[PATCH] v017 release
[thirdparty/systemd.git] / udev.spec
CommitLineData
0c675896
GKH
1# if we want to build against the included version of klibc or not.
2# 0 - do not use klibc
3# 1 - use klibc
4# Watch out for where the linux symlink is in the klibc part of the tarball,
5# it probably is not where you want it to be.
6%define klibc 1
7
05230184
GKH
8# if we want to have logging support in or not.
9# 0 - no logging support
10# 1 - logging support
11# Note, it is not recommend if you use klibc to enable logging.
12%define log 0
13
0c675896
GKH
14# if we want to build DBUS support in or not.
15# 0 - no DBUS support
16# 1 - DBUS support
17%define dbus 0
18
19# if we want to enable debugging support in udev. If it is enabled, lots of
20# stuff will get sent to the debug syslog.
21# 0 - debugging disabled
22# 1 - debugging enabled
23%define debug 0
24
e64280b8 25# if we want to use the LSB version of the init script or the Redhat one
26# 0 - use Redhat version: etc/init.d/udev
27# 1 - use LSB version: etc/init.d/udev.init.LSB
28%define lsb 0
29
3660f0b8
PM
30Summary: A userspace implementation of devfs
31Name: udev
44a523e3 32Version: 017
3660f0b8
PM
33Release: 1
34License: GPL
35Group: Utilities/System
36Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
37ExclusiveOS: Linux
e0929206 38Vendor: Greg Kroah-Hartman <greg@kroah.com>
8fc34188 39URL : kernel.org/pub/linux/utils/kernel/hotplug/
4360a56d 40BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
bbab56ba 41Prereq: /bin/sh, fileutils, hotplug
3660f0b8
PM
42
43%description
44udev is a implementation of devfs in userspace using sysfs and
22120496 45/sbin/hotplug. It requires a 2.6 kernel to run properly.
3660f0b8
PM
46
47%prep
bbab56ba 48%setup -q
3660f0b8
PM
49
50%build
0c675896
GKH
51make CC="gcc $RPM_OPT_FLAGS" \
52%if %{klibc}
53 USE_KLIBC=true \
54%endif
05230184
GKH
55%if %{log}
56 USE_LOG=true \
1659326d
GKH
57%else
58 USE_LOG=false \
05230184 59%endif
0c675896
GKH
60%if %{dbus}
61 USE_DBUS=true \
1659326d
GKH
62%else
63 USE_DBUS=false \
0c675896
GKH
64%endif
65%if %{debug}
66 DEBUG=true \
1659326d
GKH
67%else
68 DEBUG=false \
0c675896 69%endif
3660f0b8 70
d83a9b89
GKH
71# now build udevd on it's own, as it can't handle being built with klibc
72make CC="gcc $RPM_OPT_FLAGS" udevd
73
74
3660f0b8 75%install
5bfabc59 76make DESTDIR=$RPM_BUILD_ROOT install \
77%if %{dbus}
78 USE_DBUS=true
79%endif
e64280b8 80%if %{lsb}
81 USE_LSB=true
82%endif
316c5150 83%post
84/sbin/chkconfig --add udev
85
600ee7f7 86%postun
87if [ $1 = 0 ]; then
88 /sbin/chkconfig --del udev
89fi
90
3660f0b8 91%clean
bbab56ba 92rm -rf $RPM_BUILD_ROOT
3660f0b8
PM
93
94%files
ee156981 95%defattr(-,root,root)
bbab56ba
RL
96%doc COPYING README TODO ChangeLog
97%attr(755,root,root) /sbin/udev
da1cc7cc 98%attr(755,root,root) /sbin/udevinfo
d83a9b89
GKH
99%attr(755,root,root) /sbin/udevsend
100%attr(755,root,root) /sbin/udevd
bbab56ba
RL
101%attr(755,root,root) /udev/
102%attr(755,root,root) /etc/udev/
1659326d 103%attr(755,root,root) %dir
1b1dbc47 104%config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
105%config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
106%config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
5bfabc59 107%if %{dbus}
108 %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
109%endif
8634e6d1 110%attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
d870b833 111%attr(755,root,root) /etc/init.d/udev
567f6d14 112%attr(0644,root,root) %{_mandir}/man8/udev*.8*
3660f0b8
PM
113
114%changelog
1659326d
GKH
115* Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
116- add some changes from the latest Fedora udev release.
117
d83a9b89
GKH
118* Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
119- add udevsend, and udevd to the files
120- add ability to build udevd with glibc after the rest is build with klibc
121
da1cc7cc 122* Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
567f6d14 123- added udevinfo to rpm
8fc34188 124- added URL to spec file
567f6d14 125- added udevinfo's man page
da1cc7cc 126
e64280b8 127* Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
128- add defines to choose the init script (Redhat or LSB)
129
316c5150 130* Tue Dec 16 2003 Robert Love <rml@ximian.com>
131- install the initscript and run chkconfig on it
132
e8baccca
GKH
133* Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
134- changes due to config file name changes
135
bbab56ba
RL
136* Fri Oct 17 2003 Robert Love <rml@tech9.net>
137- Make work without a build root
138- Correctly install the right files
139- Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
140- Put some prereqs in
8634e6d1 141- Install the hotplug symlink to udev
bbab56ba 142
3660f0b8
PM
143* Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
144- Initial spec file for udev-0.2.